hdu 4956 Poor Hanamichi(枚举)

Poor Hanamichi

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 895    Accepted Submission(s): 408


Problem Description
Hanamichi is taking part in a programming contest, and he is assigned to solve a special problem as follow: Given a range [l, r] (including l and r), find out how many numbers in this range have the property: the sum of its odd digits is smaller than the sum of its even digits and the difference is 3.

A integer X can be represented in decimal as:
X=An×10n+An1×10n1++A2×102+A1×101+A0
The odd dights are  A1,A3,A5  and  A0,A2,A4  are even digits.

Hanamichi comes up with a solution, He notices that:
102k+1  mod 11 = -1 (or 10),  102k  mod 11 = 1, 
So X mod 11 
(An×10n+An1×10n1++A2×102+A1×101+A0)mod11
An×(1)n+An1×(1)n1++A2A1+A0
= sum_of_even_digits – sum_of_odd_digits
So he claimed that the answer is the number of numbers X in the range which satisfy the function: X mod 11 = 3. He calculate the answer in this way : 
Answer = (r + 8) / 11 – (l – 1 + 8) / 11.

Rukaw heard of Hanamichi’s solution from you and he proved there is something wrong with Hanamichi’s solution. So he decided to change the test data so that Hanamichi’s solution can not pass any single test. And he asks you to do that for him.
 

Input
You are given a integer T (1 ≤ T ≤ 100), which tells how many single tests the final test data has. And for the following T lines, each line contains two integers l and r, which are the original test data. (1 ≤ l ≤ r ≤  1018 )
 

Output
You are only allowed to change the value of r to a integer R which is not greater than the original r (and R ≥ l should be satisfied) and make Hanamichi’s solution fails this test data. If you can do that, output a single number each line, which is the smallest R you find. If not, just output -1 instead.
 

Sample Input
  
  
3 3 4 2 50 7 83
 

Sample Output
  
  
-1 -1 80

思路:直接枚举即可

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int check(long long k)
{
    long long l=k;
    int num=0;
    while(l)
    {
        l/=10;
        num++;
    }
    int lsum=0,rsum=0,flag=0;
    while(k)
    {
        if(!flag) rsum+=k%10;
        else lsum+=k%10;
        k/=10;
        flag=!flag;
    }
    if(rsum==lsum+3) return 1;
    return 0;
}
int main()
{
    int T;
    long long l,r;
    scanf("%d",&T);
    while(T--)
    {
            scanf("%lld %lld",&l,&r);
            long long num=0,v;
            long long flag=0;
            for(long long i=l; i<=r; i++)
            {
                if(check(i)) num++;
                v=(i+8)/11-(l+7)/11;
                if(v!=num)
                {
                    flag=i;
                    break;
                }
            }
            if(flag) printf("%lld\n",flag);
            else printf("-1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值