Bound Found
Time Limit: 5000MS | Memory Limit: 65536K | |||
Total Submissions: 2719 | Accepted: 826 | Special Judge |
Description
Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.
You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input
5 1 -10 -5 0 5 10 3 10 2 -9 8 -7 6 -5 4 -3 2 -1 0 5 11 15 2 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 15 100 0 0
Sample Output
5 4 4 5 2 8 9 1 1 15 1 15 15 1 15题意:题意:给个t,求一个子区间与t的差的绝对值最小。
思路:n达到了100000,此题就不能用O(n²)枚举区间来做了。考虑连续区间上的xx问题,我们可以用尺取法。可以尺取法要求区间具有单调性,这里有正有负,怎么办?
很简单,我们要求任意区间的和就需要求出前缀数组,然后我们对前缀数组排序就可以了。 排完序后你找的任意两个点都会对应原序列的一个区间(因为会取绝对值,后面减去前面也没关系) 然后用尺取法推进,找出最小的一个即可。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 100050
#define INF 2000000010
int a[N];
struct Node
{
int v,id;
}sum[N];
bool cmp(Node a,Node b)
{
return a.v<b.v;
}
int main()
{
int n,k,t;
while(~scanf("%d %d",&n,&k)&&(n+k))
{
sum[0].v=0;sum[0].id=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum[i].v=sum[i-1].v+a[i];
sum[i].id=i;
}
sort(sum,sum+1+n,cmp);
int ans;
while(k--)
{
scanf("%d",&t);
ans=INF;
int l=0,r=1;
int anss,ansl,ansr;
while(l<=n&&r<=n)
{
int w=abs(sum[r].v-sum[l].v);
int q=abs(w-t);
if(q<ans)
{
anss=w;
ans=q;
ansl=sum[l].id;
ansr=sum[r].id;
}
if(w>t) l++;
else if(w<t) r++;
else break;
if(l==r) r++;
}
if(ansl>ansr) swap(ansl,ansr);
printf("%d %d %d\n",anss,ansl+1,ansr);
}
}
return 0;
}