hdu 5059 Help him(模拟)

Help him

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2510    Accepted Submission(s): 520


Problem Description
As you know, when you want to hack someone's program, you must submit your test data. However sometimes you will submit invalid data, so we need a data checker to check your data. Now small W has prepared a problem for BC, but he is too busy to write the data checker. Please help him to write a data check which judges whether the input is an integer ranged from a to b (inclusive).
Note: a string represents a valid integer when it follows below rules.
1. When it represents a non-negative integer, it contains only digits without leading zeros.
2. When it represents a negative integer, it contains exact one negative sign ('-') followed by digits without leading zeros and there are no characters before '-'.
3. Otherwise it is not a valid integer.
 

Input
Multi test cases (about 100), every case occupies two lines, the first line contain a string which represents the input string, then second line contains a and b separated by space. Process to the end of file.

Length of string is no more than 100.
The string may contain any characters other than '\n','\r'.
-1000000000 ab1000000000
 

Output
For each case output "YES" (without quote) when the string is an integer ranged from a to b, otherwise output "NO" (without quote).
 

Sample Input
  
  
10 -100 100 1a0 -100 100
 

Sample Output
  
  
YES NO
题意:给你一个字符串,先判断字符串是否是合法的数字,在判断是否是给定区间里的数

思路:直接模拟,注意字符串会有空格,注意用long long 十位数组可能会有50E超过int范围

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int main()
{
    char s[510];
    long long a,b;
    while(gets(s))
    {
        scanf("%lld %lld",&a,&b);
        int len=strlen(s);
        int flag=0;
        if(s[0]!='-'&&(s[0]<'0'||s[0]>'9'))
            flag=1;
        for(int i=1; i<len; i++)
            if(s[i]<'0'||s[i]>'9')
                flag=1;
        if(s[0]=='-'&&(len==1||s[1]=='0'))
            flag=1;
        if(len>1&&s[0]=='0')
            flag=1;
        if(flag) printf("NO\n");
        else
        {
            if(len>11) printf("NO\n");
            else
            {
                long long ans=0;
                if(s[0]=='-')
                {
                    for(int i=1;i<len;i++)
                        ans=ans*10+s[i]-'0';
                    ans=-ans;
                }
                else
                     for(int i=0;i<len;i++)
                        ans=ans*10+s[i]-'0';
                if(ans>=a&&ans<=b) printf("YES\n");
                else printf("NO\n");
            }
        }
        getchar();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值