hdu 2896 病毒侵袭(AC自动机)

病毒侵袭

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20363    Accepted Submission(s): 4976


Problem Description
当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 

Input
第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 

Sample Input
  
  
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

Sample Output
  
  
web 1: 1 2 3 total: 1
 
题意:中文题不解释题意

思路:前面的操作跟常规的AC自动机一样,只是我们需要在结构体里加入一些额外的保存信息,比如当前字符串的编号,是否被遍历过等等

因为后面需要跟多个串进行比较,所以不能直接把权值赋为-1,所以我们多加一个标记,每次标记为i即可(每一次进入新的字符串,i都会加一,但是在当前的字符串,i标记了后就不能再进去了)

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 300
#define M 10050
char s[N],str[M];
int a[M],t;
struct Node
{
    struct Node *next[128];
    struct Node *fail;
    int num,flag;
    void init()
    {
        for(int i=0; i<128; i++)
            next[i]=NULL;
        fail=NULL;
        num=0;
        flag=0;
    }
}*root;
void Insert(int id)
{
    Node *p=root;
    int len=strlen(s);
    for(int i=0; i<len; i++)
    {
        int pos=s[i];
        if(p->next[pos]==NULL)
        {
            p->next[pos]=new Node;
            p->next[pos]->init();
        }
        p=p->next[pos];
    }
    p->num=id;
}
void getfail()
{
    Node *p=root,*now,*son;
    queue<Node *>que;
    que.push(p);
    while(!que.empty())
    {
        now=que.front();
        que.pop();
        for(int i=0; i<128; i++)
        {
            son=now->next[i];
            if(son!=NULL)
            {
                if(now==root) son->fail=root;
                else
                {
                    p=now->fail;
                    while(p)
                    {
                        if(p->next[i])
                        {
                            son->fail=p->next[i];
                            break;
                        }
                        p=p->fail;
                    }
                    if(!p) son->fail=root;
                }
                que.push(son);
            }
        }
    }
}
void query(int id)
{
    Node *p=root,*temp;
    int len=strlen(str);
    for(int i=0; i<len; i++)
    {
        int pos=str[i];
        while(!p->next[pos]&&p!=root) p=p->fail;
        p=p->next[pos];
        if(!p) p=root;
        temp=p;
        while(temp!=root)
        {
            if(t>=3) break;
            if(temp->num>0&&temp->flag!=id)
            {
                a[t++]=temp->num;
                temp->flag=id;
            }
            else break;
            temp=temp->fail;
        }
        if(t>=3) break;
    }
}
int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
        root=new Node;
        root->init();
        getchar();
        for(int i=1; i<=n; i++)
        {
            gets(s);
            Insert(i);
        }
        getfail();
        scanf("%d",&m);
        int ans=0;
        getchar();
        for(int k=1; k<=m; k++)
        {
            t=0;
            gets(str);
            query(k);
            if(t>0)
            {
                ans++;
                sort(a,a+t);
                printf("web %d: ",k);
                for(int i=0; i<t-1; i++)
                    printf("%d ",a[i]);
                printf("%d\n",a[t-1]);
            }
        }
        printf("total: %d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
Antique Comedians of Malidinesia would like to play a new discovered comedy of Aristofanes. Putting it on a stage should be a big surprise for the audience so all the preparations must be kept absolutely secret. The ACM director suspects one of his competitors of reading his correspondece. To prevent other companies from revealing his secret, he decided to use a substitution cipher in all the letters mentioning the new play. Substitution cipher is defined by a substitution table assigning each character of the substitution alphabet another character of the same alphabet. The assignment is a bijection (to each character exactly one character is assigned -- not neccessary different). The director is afraid of disclosing the substitution table and therefore he changes it frequently. After each change he chooses a few words from a dictionary by random, encrypts them and sends them together with an encrypted message. The plain (i.e. non-encrypted) words are sent by a secure channel, not by mail. The recipient of the message can then compare plain and encrypted words and create a new substitution table. Unfortunately, one of the ACM cipher specialists have found that this system is sometimes insecure. Some messages can be decrypted by the rival company even without knowing the plain words. The reason is that when the director chooses the words from the dictionary and encrypts them, he never changes their order (the words in the dictionary are lexicographically sorted). String a1a2 ... ap is lexicografically smaller than b1b2 ... bq if there exists an integer i, i <= p, i <= q, such that aj=bj for each j, 1 <= j < i and ai < bi. The director is interested in which of his messages could be read by the rival company. You are to write a program to determine that. Input Output Sample Input 2 5 6 cebdbac cac ecd dca aba bac cedab 4 4 cca cad aac bca bdac Sample Output abcde Message cannot be decrypted.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值