poj 1932 XYZZY(SPFA)

XYZZY
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3695 Accepted: 1060

Description

The prototypical computer adventure game, first designed by Will Crowther on the PDP-10 in the mid-1970s as an attempt at computer-refereed fantasy gaming, and expanded into a puzzle-oriented game by Don Woods at Stanford in 1976. (Woods had been one of the authors of INTERCAL.) Now better known as Adventure or Colossal Cave Adventure, but the TOPS-10 operating system permitted only six-letter filenames in uppercase. See also vadding, Zork, and Infocom. 

It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. 

Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 

Input

The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 
  • the energy value for room i 
  • the number of doorways leaving room i 
  • a list of the rooms that are reachable by the doorways leaving room i

The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output

In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".

Sample Input

5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1

Sample Output

hopeless
hopeless
winnable
winnable
题意:有n个房间,每个房间会跟其他m个房间连接,经过一个房间需要加上该房间的能量,初始能量值是100,当能量<=0的时候就死了,问能否从一号房间走到n号房间

思路:此题可能有正环和负环,所以我们可以转换为求最长路,这样负环就不会重复走了。

当出现正环的时候,把权值赋为INF,表示这里可以取到无穷大的权值,这样不管后面负数有多大都能走过去

最后判断d[n]即可

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 210
#define INF 1000000009
struct Edge
{
    int v,w,next;
} edge[N*N];
int cnt,head[N],n;
int vis[N],d[N],num[N];
void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int w)
{
    edge[cnt].v=v,edge[cnt].w=w;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
void spfa(int s)
{
    memset(vis,0,sizeof(vis));
    memset(num,0,sizeof(num));
    for(int i=1; i<=n; i++)
        d[i]=i==s?100:-INF;
    vis[s]=1;
    queue<int>que;
    que.push(s);
    while(!que.empty())
    {
        int u=que.front();
        que.pop();
        vis[u]=0;
        num[u]++;
        if(num[u]>n) d[u]=INF;
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            int v=edge[i].v,w=edge[i].w;
            if(d[u]+w>0&&d[v]<d[u]+w)
            {
                d[v]=d[u]+w;
                if(!vis[v]&&num[v]<=n)
                {
                    vis[v]=1;
                    que.push(v);
                }
            }
        }
    }
}
int main()
{
    int e,m,t;
    while(~scanf("%d",&n)&&n!=-1)
    {
        init();
        for(int i=1; i<=n; i++)
        {
            scanf("%d %d",&e,&m);
            while(m--)
            {
                scanf("%d",&t);
                addedge(i,t,e);
            }
        }
        spfa(1);
        if(d[n]>0) printf("winnable\n");
        else printf("hopeless\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值