hdu 3729 I'm Telling the Truth(二分图最大匹配,字典序最大输出)

I'm Telling the Truth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1997    Accepted Submission(s): 1007


Problem Description
After this year’s college-entrance exam, the teacher did a survey in his class on students’ score. There are n students in the class. The students didn’t want to tell their teacher their exact score; they only told their teacher their rank in the province (in the form of intervals).

After asking all the students, the teacher found that some students didn’t tell the truth. For example, Student1 said he was between 5004th and 5005th, Student2 said he was between 5005th and 5006th, Student3 said he was between 5004th and 5006th, Student4 said he was between 5004th and 5006th, too. This situation is obviously impossible. So at least one told a lie. Because the teacher thinks most of his students are honest, he wants to know how many students told the truth at most.
 

Input
There is an integer in the first line, represents the number of cases (at most 100 cases). In the first line of every case, an integer n (n <= 60) represents the number of students. In the next n lines of every case, there are 2 numbers in each line, X i and Y i (1 <= X i <= Y i <= 100000), means the i-th student’s rank is between X i and Y i, inclusive.

 

Output
Output 2 lines for every case. Output a single number in the first line, which means the number of students who told the truth at most. In the second line, output the students who tell the truth, separated by a space. Please note that there are no spaces at the head or tail of each line. If there are more than one way, output the list with maximum lexicographic. (In the example above, 1 2 3;1 2 4;1 3 4;2 3 4 are all OK, and 2 3 4 with maximum lexicographic)
 

Sample Input
  
  
2 4 5004 5005 5005 5006 5004 5006 5004 5006 7 4 5 2 3 1 2 2 2 4 4 2 3 3 4
 

Sample Output
  
  
3 2 3 4 5 1 3 5 6 7
 
题意:有n个学生, 每个学生有一个成绩的区间,现在问最多能有几个学生说了真话,学生编号按字典序尽量大输出

思路:对一个学生,把整个区间里的数都连上当作一条边,表示这个学生可以选择任意一个成绩,然后跑一遍最大匹配即可

字典序的话只要逆序遍历出来的就是字典序大的

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 61
#define M 100001
#define INF 999999999
int ma[N][M];
int n,line[M],vis[M];
int anss[N];
int l,r;
int can(int t)
{
    for(int i=l; i<=r; i++)
    {
        if(!vis[i]&&ma[t][i])
        {
            vis[i]=1;
            if(line[i]==-1||can(line[i]))
            {
                line[i]=t;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int k,T;
    int x,y;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(line,-1,sizeof(line));
        memset(ma,0,sizeof(ma));
        l=INF,r=-1;
        for(int i=1; i<=n; i++)
        {
            scanf("%d %d",&x,&y);
            l=min(l,x);
            r=max(r,y);
            for(int j=x;j<=y;j++)
                ma[i][j]=1;
        }
        int ans=0;
        for(int i=n; i>=1; i--)
        {
            for(int j=l;j<=r;j++)
                vis[j]=0;
            if(can(i))
                ans++;
        }
        printf("%d\n",ans);
        int cnt=0;
        for(int i=l;i<=r;i++)
            if(line[i]>0)
                anss[cnt++]=line[i];
        sort(anss,anss+cnt);
        for(int i=0;i<cnt-1;i++)
            printf("%d ",anss[i]);
        printf("%d\n",anss[cnt-1]);
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值