hdu 5804 Price List(水题 )

Price List

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 97    Accepted Submission(s): 69


Problem Description
There are  n  shops numbered with successive integers from  1  to  n  in Byteland. Every shop sells only one kind of goods, and the price of the  i -th shop's goods is  vi .

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar's poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn't used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.
 

Input
The first line of the input contains an integer  T   (1T10) , denoting the number of test cases.

In each test case, the first line of the input contains two integers  n,m   (1n,m100000) , denoting the number of shops and the number of records on Byteasar's account book.

The second line of the input contains  n  integers  v1,v2,...,vn   (1vi100000) , denoting the price of the  i -th shop's goods.

Each of the next  m  lines contains an integer  q   (0q1018) , denoting each number on Byteasar's account book.
 

Output
For each test case, print a line with  m  characters. If the  i -th number is sure to be strictly larger than the actual value, then the  i -th character should be '1'. Otherwise, it should be '0'.
 

Sample Input
  
  
1 3 3 2 5 4 1 7 10000
 

Sample Output
  
  
001
 
题意:在Byteland一共有n家商店,编号依次为1到n。每家商店只会卖一种物品,其中第i家商店的物品单价为vi

Byteasar每天都会进行一次购物,他会在每家商店购买最多一件物品,当然他也可以选择什么都不买。回家之后,Byteasar会把这一天购物所花的钱的总数记录在账本上。


Byteasar的数学不好,他可能会把花的钱记少,也可能记多。Byteasar并不介意记少,因为这样看上去显得自己没花很多钱。


请写一个程序,帮助Byteasar判断每条记录是否一定记多了。

思路:输入一个q判断是不是大于sum即可

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 100050
int v[N];
int main()
{
    int T,n,m;
    long long t;
    scanf("%d",&T);
    while(T--)
    {
        long long sum=0;
        scanf("%d %d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&v[i]);
            sum+=v[i];
        }
        while(m--)
        {
            scanf("%lld",&t);
            if(t>sum)
                printf("1");
            else printf("0");
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值