hdu 5927 Auxiliary Set(思路)

Auxiliary Set

Time Limit: 9000/4500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 813    Accepted Submission(s): 256


Problem Description
Given a rooted tree with n vertices, some of the vertices are important.

An auxiliary set is a set containing vertices satisfying at least one of the two conditions:

It is an important vertex
It is the least common ancestor of two different important vertices.

You are given a tree with n vertices (1 is the root) and q queries.

Each query is a set of nodes which indicates the  unimportant vertices in the tree. Answer the size (i.e. number of vertices) of the auxiliary set for each query.
 

Input
The first line contains only one integer T ( T1000 ), which indicates the number of test cases.

For each test case, the first line contains two integers n ( 1n100000 ), q ( 0q100000 ).

In the following n -1 lines, the i-th line contains two integers  ui,vi(1ui,vin)  indicating there is an edge between  ui i and  vi  in the tree.

In the next q lines, the i-th line first comes with an integer  mi(1mi100000)  indicating the number of vertices in the query set.Then comes with mi different integers, indicating the nodes in the query set.

It is guaranteed that  qi=1mi100000 .

It is also guaranteed that the number of test cases in which  n1000   or  qi=1mi1000  is no more than 10.
 

Output
For each test case, first output one line "Case #x:", where x is the case number (starting from 1).

Then q lines follow, i-th line contains an integer indicating the size of the auxiliary set for each query. 
 

Sample Input
  
  
1 6 3 6 4 2 5 5 4 1 5 5 3 3 1 2 3 1 5 3 3 1 4
 

Sample Output
  
  
Case #1: 3 6 3
Hint
For the query {1,2, 3}: •node 4, 5, 6 are important nodes For the query {5}: •node 1,2, 3, 4, 6 are important nodes •node 5 is the lea of node 4 and node 3 For the query {3, 1,4}: • node 2, 5, 6 are important nodes
详情看这篇题解,写的十分详细。

http://www.cnblogs.com/hahatianx/p/5943435.html

受益匪浅,还能从这个角度去做题...

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 100005
struct Edge
{
    int next,v;
} edge[N*4];
struct Node
{
    int v,d;
} node[N];
int cnt,head[N];
int son_num[N],dep[N],father[N],temp_son_num[N];
void init()
{
    cnt=0;
    memset(head,-1,sizeof(head));
    memset(son_num,0,sizeof(son_num));
}
void addedge(int u,int v)
{
    edge[cnt].v=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
int dfs(int u,int k,int d)
{
    dep[u]=d;
    father[u]=k;
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(v==k) continue;
        son_num[u]++;
        dfs(v,u,d+1);
    }
}
bool cmp(Node a,Node b)
{
    return a.d>b.d;
}
int main()
{
    int T,n,m;
    int Tcase=1;
    int u,v,t,l;
    scanf("%d",&T);
    while(T--)
    {
        init();
        scanf("%d %d",&n,&m);
        for(int i=1; i<n; i++)
        {
            scanf("%d %d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        dfs(1,-1,1);
        printf("Case #%d:\n",Tcase++);
        while(m--)
        {
            scanf("%d",&t);
            int ans=n-t,c=0;
            for(int i=1; i<=t; i++)
            {
                scanf("%d",&l);
                temp_son_num[l]=son_num[l];
                node[c].v=l,node[c++].d=dep[l];
            }
            sort(node,node+c,cmp);
            for(int i=0; i<c; i++)
            {
                int pos=node[i].v;
                if(temp_son_num[pos]>=2) ans++;
                else if(temp_son_num[pos]==0) temp_son_num[father[pos]]--;
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值