B - ss

B - ss
Time limit : 2sec / Memory limit : 256MB

Score : 200 points

Problem Statement
We will call a string that can be obtained by concatenating two equal strings an even string. For example, xyzxyz and aaaaaa are even, while ababab and xyzxy are not.

You are given an even string S consisting of lowercase English letters. Find the length of the longest even string that can be obtained by deleting one or more characters from the end of S. It is guaranteed that such a non-empty string exists for a given input.

Constraints
2≤|S|≤200
S is an even string consisting of lowercase English letters.
There exists a non-empty even string that can be obtained by deleting one or more characters from the end of S.
Input
Input is given from Standard Input in the following format:

S
Output
Print the length of the longest even string that can be obtained.

Sample Input 1
Copy
abaababaab
Sample Output 1
Copy
6
abaababaab itself is even, but we need to delete at least one character.
abaababaa is not even.
abaababa is not even.
abaabab is not even.
abaaba is even. Thus, we should print its length, 6.
Sample Input 2
Copy
xxxx
Sample Output 2
Copy
2
xxx is not even.
xx is even.
Sample Input 3
Copy
abcabcabcabc
Sample Output 3
Copy
6
The longest even string that can be obtained is abcabc, whose length is 6.

Sample Input 4
Copy
akasakaakasakasakaakas
Sample Output 4
Copy
14
The longest even string that can be obtained is akasakaakasaka, whose length is 14.

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    char s[210];
    while(cin>>s)
    {
        int len=strlen(s);
        len--;//先去掉最后一个
        if(len%2!=0)//保证有偶数个
        {
            len--;
        }
        int i,j,k;
        for(i=len/2;i!=0;len=len-2,i=len/2)//找到字符串的中间位置
        {
            for(j=0,k=i;k<len;j++,k++)
            {
                if(s[j]!=s[k])
                break;
            }
            if(k==len)//出现前后相同的字符串
            {
                break;
            }
        }
        if(i==0)
        {
            printf("0\n");
        }
        else
        {
             printf("%d\n",len);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值