6573: ss (石油大学, 暑假集训题)

6573: ss

时间限制: 1 Sec  内存限制: 128 MB
提交: 101  解决: 61
[提交] [状态] [讨论版] [命题人:admin]

题目描述

We will call a string that can be obtained by concatenating two equal strings an even string. For example, xyzxyz and aaaaaa are even, while ababab and xyzxy are not.
You are given an even string S consisting of lowercase English letters. Find the length of the longest even string that can be obtained by deleting one or more characters from the end of S. It is guaranteed that such a non-empty string exists for a given input.

Constraints
2≤|S|≤200
S is an even string consisting of lowercase English letters.
There exists a non-empty even string that can be obtained by deleting one or more characters from the end of S.

 

输入

Input is given from Standard Input in the following format:
S

 

输出

Print the length of the longest even string that can be obtained.

 

样例输入

abaababaab

 

样例输出

6

 

提示

abaababaab itself is even, but we need to delete at least one character.
abaababaa is not even.
abaababa is not even.
abaabab is not even.
abaaba is even. Thus, we should print its length, 6.

 

来源/分类

ABC066&ARC077 

 

解析:这一题没啥,减去末尾的一个,判一下是不是,是就输出此时长度,否则继续下去就好了。

 

#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    string str;
    int len, flag, i;
    while(cin >> str){
        flag = 0;
        len = str.length();
        len--; //至少去掉一个
        if(len % 2 == 1)
            len--;
        for(i = len; i >= 2; i -= 2){
            if(!str.compare(0, i/2, str, i/2, i/2)){  //截成两半后如果相等
                //cout << i << endl;
                flag = 1;
                break;
            }
        }
        if(flag){
            cout << i << endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值