1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

一遍就ac的题,好爽^-^。本次题意:输入m和n,m代表有几组数据,n代表每组数据的个数,接下来输入m组数据,每组数据代表 一个二叉树的层序遍历序列,输出则是判断每组数据是大顶堆还是小顶堆,或者都不是,判断完,后序输出该二叉树。下面是代码

#include<iostream>
#include<vector>
int book;
using namespace std;
typedef struct node{
	int data;
	struct node *l,*r;
}tree;
tree* creat(int v[1001],int n,int i){
	tree *root;
	if(i > n){
		root = NULL;
	}else{
		root = (tree *)malloc(sizeof(tree));
		root->data = v[i];
		root->l = creat(v,n,i*2);
		root->r = creat(v,n,i*2+1);
	}
	return root;
}
void lrd(tree *root){
	if(root == NULL){
		return ;
	}else{
		lrd(root->l);
		lrd(root->r);
		if(book==0){
			cout << root->data;
			book = 1;
		}else{
			cout << " " <<  root->data;
		}
	}
}
int main(){
	int m,n;
	tree *root;
	cin >> m >> n;
	while(m--){
		book = 0;
		int fmax = 0,fmin = 0,flag = 0;
		int v[1001];
		for(int i = 1;i <= n;i++){
			cin >> v[i];
		}
		root = creat(v,n,1);
		for(int i = 2;i <= n;i++){
			if(v[i/2] > v[i]){
				fmax = 1;
			}
			else if(v[i/2] < v[i]){
				fmin = 1;
			}else{
				flag = 1;
			}
		}
		if(flag==1 || (fmax == 1 && fmin == 1)){
			cout << "Not Heap" << endl; 
		}else if(fmax==1 && fmin != 1){
			cout << "Max Heap" << endl;
		}else if(fmin==1 && fmax != 1){
			cout << "Min Heap" << endl;
		}
		lrd(root);
		cout << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值