HDU1532 Drainage Ditches (网络流基础水题)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9281    Accepted Submission(s): 4361


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
    
    
5 4
1 2 40
20 2 3
1 4 20
2 4 30
3 4 10
 

Sample Output
    
    
50
 

Source
 

题解:网络流的模板题。下面用的是Dinic来做。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <set>
#include <ctime>
#include <queue>
#include <numeric>
#include <list>
#include <functional>

using namespace std; 

#define eps 1e-8
#define LL long long
#define ULL unsigned long long
#define mod 1000000007
#define MP make_pair
#define PII pair<int, int>
#define INF 0x3f3f3f3f

struct Edge {
	int from, to, cap, flow;
	Edge() {}
	Edge(int a, int b, int c, int d):from(a), to(b), cap(c), flow(d) {}
};

const int maxn = 205;

struct Dinic {
	int n, m, s, t;
	vector<Edge> edges;
	vector<int> G[maxn];
	bool vis[maxn];
	int d[maxn];
	int cur[maxn];

	void init()
	{
		for (int i = 0; i <= n; ++i)
		{
			G[i].clear();
		}
		edges.clear();
	}

	void add(int from, int to, int cap)
	{
		edges.push_back(Edge(from, to, cap, 0));
		edges.push_back(Edge(to, from, 0, 0));
		int e = edges.size();
		G[from].push_back(e - 2);
		G[to].push_back(e-1);
	}


	bool BFS()
	{
		memset(vis, 0, sizeof(vis));
		queue<int> Q;
		Q.push(s);
		d[s] = 0; vis[s] = 1;
		while (!Q.empty())
		{
			int x = Q.front(); Q.pop();
			for (int i = 0; i < G[x].size(); ++i)
			{
				Edge& e = edges[G[x][i]];
				if (!vis[e.to] && e.cap > e.flow)
				{
					vis[e.to] = 1;
					d[e.to] = d[x] + 1;
					Q.push(e.to);
				}
			}
		}
		return vis[t];
	}
	
	int DFS(int x, int a) {
		if (x == t || a == 0)  return a;
		int flow = 0, f;
		for (int& i = cur[x]; i < G[x].size(); ++i)
		{
			Edge& e = edges[G[x][i]];
			if (d[x] + 1 == d[e.to] && (f = DFS(e.to, min(a, e.cap - e.flow))) > 0) 
			{
				e.flow += f;
				edges[G[x][i]^1].flow -= f;
				flow += f;
				a -= f;
				if (a  == 0) break;
			}
		}
		return flow;
	}

	int Maxflow(int s, int t)
	{
		this->s = s; this->t = t;
		int flow = 0;
		while (BFS())
		{
			memset(cur, 0, sizeof(cur));
			flow += DFS(s, INF);
		}
		return flow;
	}


}ans;

int main()
{
	int u, v, c;
	while (~scanf("%d%d", &ans.m, &ans.n))
	{
		ans.init();
		for (int i = 0; i < ans.m; ++i)
		{
			scanf("%d%d%d", &u, &v, &c);
			ans.add(u, v, c);
			
		}
		printf("%d\n", ans.Maxflow(1, ans.n));
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值