【水题】hdoj1203 Doubles

Doubles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3424    Accepted Submission(s): 2403


Problem Description
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list 
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9. 
 

Input
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
 

Output
The output will consist of one line per input list, containing a count of the items that are double some other item.
 

Sample Input
  
  
1 4 3 2 9 7 18 22 0 2 4 8 10 0 7 5 11 13 1 3 0 -1
 

Sample Output
  
  
3 2 0
没什么好说的,十分水。
【代码】
#include<iostream>
#include<algorithm>
using namespace std;
int db[20];
int sl[20];
int main() {
	int m, n;
	int ii;
	while (cin >> m&&m != -1) {
		memset(db, 0, sizeof(db));
		memset(sl, 0, sizeof(sl));
		ii = 0;
		sl[ii] = m;
		db[ii] = m * 2;
		ii++;
		while (cin >> n&&n) {
			sl[ii] = n;
			db[ii] = n * 2;
			ii++;
		}
		sort(db, db + ii);
		sort(sl, sl + ii);
		int total = 0;
		for (int zz = 0; zz < ii; zz++) {
			int *p = find(db, db + ii, sl[zz]);
			if (p != db + ii)total++;
		}
		cout << total << endl;
	}
	return 0;
}

注意一下find函数
template<class InputIterator, class T>
InputIterator find (InputIterator first, InputIterator last, const T& val)
{
  while (first!=last) 
  {
     if (*first==val) return first;
     ++first;
   }
    return last;
}
【vector判断】 #include<algorithm>
find(v.begin(),v.end(),待查找)==v.end()
【数组判断】 #include<algorithm>
find(a,a+len,待查找)
T *p=a+len(作为判断准则)
【string判断】#include<string>
string s, ss;
	cin >> s >> ss;
	string::size_type position;
	position = s.find(ss);//
	if (position == string::npos)cout << "NOT FOUND" << endl;//此处也可是s.npos
	else cout << position;
find_first_of(待查找);
find(待查找,指定开始位置)
find_first_of(待查找,指定开始位置)//都用到了position(string::size_type)以及string::npos
find_last_of//同上
find_first_not_of(待匹配)第一个不匹配字符位置,返回0。用不到string::npos
find_last_not_of//同上
rfind(待查找)反向查找,最后一次出现位置
【set判断】#include<algorithm> #include<set>
set自身有find函数
find(s.begin(),s.end(),待查找)==s.end()


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值