文章标题 Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

  • Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
    Output
  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

  • Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20

Sample Output
90

Hint
INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题意:T条边,N个顶点,求从N走到1的最短路

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int map[1001][1001];
int dis[1009],book[1009];
int main()
{
    int T,N,u;
    int inf=99999999;
    while(~scanf("%d%d",&T,&N))
    {
        int minn;
        int i,j,a,b,c;
        for(i=1;i<=N;i++)//初始化
            for(j=1;j<=N;j++)
            {
                if(i==j)
                    map[i][j]=0;
                else
                    map[i][j]=inf;
            }
        for(i=0;i<T;i++)//读入边
        {
            scanf("%d%d%d",&a,&b,&c);
            map[a][b]=map[b][a]=min(c,map[a][b]);//有重边
        }
        for(i=1;i<=N;i++)
            dis[i]=map[1][i];//初始化did数组,源点到各顶点的初始路程
        memset(book,0,sizeof(book));
        book[1]=1;
        for(i=1;i<N;i++)
        {//找到离源点最近的顶点
            minn=inf;
            for(int j=1;j<=N;j++)
            {
                if(!book[j]&&dis[j]<minn)//不能是找过的
                {
                    minn=dis[j];
                    u=j;
                }
            }
            book[u]=1;
            for(int k=1;k<=N;k++)//松弛各点到源点的距离
            {
                if(map[u][k]<inf&&dis[k]>dis[u]+map[u][k])
                    dis[k]=dis[u]+map[u][k];
            }
        }
        printf("%d\n",dis[N]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值