Treasure Exploration

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?
Input
The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.
Output
For each test of the input, print a line containing the least robots needed.
Sample Input
1 0
2 1
1 2
2 0
0 0
Sample Output
1
1
2

题意:有那个点,m个边,问最少放几个robots可以探索全部的点,重点是可以重复探索一个点;


参考:最小路径覆盖问题值得注意的地方


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<string>
using namespace std;
const int MAXN=500+10;
int line[MAXN][MAXN];
char s[MAXN][MAXN];
int mp[MAXN][MAXN];
int flag[MAXN],vast[MAXN];
int n,m,k;
void folyd()
{
    for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
         for(int j=1;j<=n;j++)
         if(line[i][k]&&line[k][j])
         line[i][j]=1;
}
int Find(int v)
{
    for(int i=1;i<=n;i++)
    {
        if(!vast[i]&&line[v][i])
        {
            vast[i]=1;
            if(!flag[i]||Find(flag[i]))
            {
                flag[i]=v;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
   while(~scanf("%d%d",&n,&m))
   {
       if(!n&&!m) break;
       memset(line,0,sizeof(line));
       int a,b;
       for(int i=0;i<m;i++)
       {
           scanf("%d%d",&a,&b);
           line[a][b]=1;
       }
       folyd();
       memset(flag,0,sizeof(flag));
       int ans=0;
       for(int i=1;i<=n;i++)
       {
           memset(vast,0,sizeof(vast));
           if(Find(i))
            ans++;
       }
       printf("%d\n",n-ans);
   }
   return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值