Happy Necklace

Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly n beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo 109+7.
Note: The necklace is a single string, {not a circle}.
Input
The first line of the input contains an integer T(1≤T≤10000), denoting the number of test cases.
For each test case, there is a single line containing an integer n(2≤n≤1018), denoting the number of beads on the necklace.
Output
For each test case, print a single line containing a single integer, denoting the answer modulo 109+7.
Sample Input
2
2
3
Sample Output
3
4
题意·:一个手链只有红色和蓝色的珠子,假设红色是1,蓝色是0,在任意的素数个数的珠子中红色大于等于蓝色,分析可知若要满足条件只需要考虑长度为2和长度为3的串。


先找出递推公式f[n]=f[n-1]+f[n-3];
由于n的数据过大,可以用矩阵快速幂的方法求;
先由递推公式求出矩阵 f[n+1]=f[n]+f[n-2]
………………………… f[n]=f[n]
…………………………f[n-2]=f[n-2]
这里写图片描述

因此关系矩阵为101 ,初始矩阵为 200
…………………100 ,……………..400
…………………010 ,……………..600

#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<map>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f3f3f3f;
const int MAXN=100+10;
const ll mod=1000000007;
struct matrix
{
    ll x[10][10];
    matrix()
    {
        mem(x,0);
    }
};
ll n;
matrix mul(matrix r,matrix m)
{
    matrix answer;
    for(int i=1; i<=3; i++)
    {
        for(int j=1; j<=3; j++)
        {
            for(int k=1; k<=3; k++)
            {
                answer.x[i][j]+=(r.x[i][k]*m.x[k][j])%mod;
                answer.x[i][j]%=mod;
            }
        }
    }//cout<<"<3>"<<endl;for(int i=1;i<=3;i++){for(int j=1;j<=3;j++) cout<<answer.x[i][j]<<" ";cout<<endl;  }
    return answer;
}
matrix solve(matrix A,ll m)
{
    matrix rax;
    rax.x[1][1]=1;
    rax.x[2][2]=1;
    rax.x[3][3]=1;
    while(m)
    {
        if(m&1){
            rax=mul(rax,A);//cout<<"<2>"<<endl;for(int i=1;i<=3;i++){for(int j=1;j<=3;j++) cout<<rax.x[i][j]<<" ";cout<<endl;  }cout<<endl;
            }
        A=mul(A,A);
        m>>=1;
    }
    return rax;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld",&n);
        matrix A;
        A.x[1][1]=6;
        A.x[2][1]=4;
        A.x[3][1]=3;
        matrix B;
        B.x[1][1]=1;B.x[1][2]=0;B.x[1][3]=1;
        B.x[2][1]=1;B.x[2][2]=0;B.x[2][3]=0;
        B.x[3][1]=0;B.x[3][2]=1;B.x[3][3]=0;
        if(n==2) {printf("3\n");continue;}
        if(n==3) {printf("4\n");continue;}
        if(n==4) {printf("6\n");continue;}
        matrix answer=solve(B,n-4);//cout<<"<1>"<<endl;for(int i=1;i<=3;i++){for(int j=1;j<=3;j++) cout<<answer.x[i][j]<<" ";cout<<endl;  }
        answer=mul(answer,A);//for(int i=1;i<=3;i++){for(int j=1;j<=3;j++) cout<<answer.x[i][j]<<" ";cout<<endl;  }
        printf("%lld\n",answer.x[1][1]%mod);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值