hdu 6030 Happy Necklace



Problem Description
Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly  n  beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo  109+7 .
Note: The necklace is a single string,  {not a circle}.
 

Input
The first line of the input contains an integer  T(1T10000) , denoting the number of test cases.
For each test case, there is a single line containing an integer  n(2n1018) , denoting the number of beads on the necklace.
 

Output
For each test case, print a single line containing a single integer, denoting the answer modulo  109+7 .
 

Sample Input
  
  
2 2 3
 

Sample Output
  
  
3 4


题意:有红蓝两种颜色的珠子,要组成一个长串(不成环),对任意连续素数数个串需满足红珠子数不大于蓝珠子数,给出串的长度统计有多少种情况。

思路:推出递推式f(n) = f(n-1)+f(n-3),然后构造矩阵,矩阵快速幂


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<stack>

using namespace std;

const double EXP = 1e-9;
typedef long long ll;
const ll maxn =  3;  //确定矩阵大小
const ll mod =   1e9+7;  //取余数用

struct mat
{
    ll m[maxn][maxn];
}unit;   //unit为单位矩阵

mat matmul(mat a,mat b)  //俩矩阵相乘
{
    mat ans;
    ll x,i,j,k;
    for(i=0;i<maxn;i++)
    {
        for(j=0;j<maxn;j++)
        {
            x=0;
            for(k=0;k<maxn;k++)
            {
                x+=(a.m[i][k]*b.m[k][j])%mod;
            }
            ans.m[i][j] = x%mod;
        }
    }
    return ans;
}

void init_unit()   //初始化单位矩阵
{
    for(ll i=0;i<maxn;i++)
        unit.m[i][i] = 1;
    return ;
}

mat pow_mat(mat a,ll n)  //矩阵快速幂,求矩阵a的n次幂
{
    mat ans = unit;  //unit为幺元
    while(n)
    {
        if(n&1)
            ans=matmul(ans,a);
        a = matmul(a,a);
        n>>=1;
    }
    return ans;
}

int main()
{
    ll n,t;
    init_unit();
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&n);
        if(n==2)
            printf("3\n");
        else if(n==3)
            printf("4\n");
        else if(n==4)
            printf("6\n");
        else
        {
            mat a,b;   //a为表达式矩阵,b为快速幂矩阵
            b.m[0][0]=1,b.m[0][1]=1,b.m[0][2]=0;
            b.m[1][0]=0,b.m[1][1]=0,b.m[1][2]=1;
            b.m[2][0]=1,b.m[2][1]=0,b.m[2][2]=0;

            a.m[0][0]=6, a.m[0][1]=4,a.m[0][2]=3;
            b = pow_mat(b,n-4);
            a = matmul(a,b);
            printf("%lld\n",a.m[0][0]%mod);
        }
    }
    return 0;
}








Problem Description
Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly  n  beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo  109+7 .
Note: The necklace is a single string,  {not a circle}.
 

Input
The first line of the input contains an integer  T(1T10000) , denoting the number of test cases.
For each test case, there is a single line containing an integer  n(2n1018) , denoting the number of beads on the necklace.
 

Output
For each test case, print a single line containing a single integer, denoting the answer modulo  109+7 .
 

Sample Input
   
   
2 2 3
 

Sample Output
   
   
3 4
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值