pat甲级1010. Radix (25)

1010. Radix (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:

Impossible

题意分析:

1.考虑二分进制,比较该进制下数字的大小,范围是[B各个位的最大值,A的值]
2.如果B只有一位,那就是判断B是否等于A,一步即可,范围是[B各个位的最大值,A的值]
     1)A的值和B一样,显然可以,那么范围内其实就一个数,带入二分程序
     2)A的值和B不一样,无论大小,显然是Impossible,带入二分程序,每次比较他们都不会一致

AC代码如下:

#include<stdio.h>
#include<string.h>
#include<map>
using namespace std;
map<char,long long>mm;
long long getlow(char n[])
{
        long long maxx=-1;
        for(long long i=0;i<strlen(n);i++)
        {
                if(maxx<mm[n[i]])
                        maxx=mm[n[i]];
        }
        return maxx+1;
}
long long getx(char n[],long long radix)
{
        long long sum=0;
        for(long long i=0;i<strlen(n);i++)
        {
                sum=sum*radix+mm[n[i]];
        }
        return sum;
}
long long compare(char n[],long long x,long long radix)
{
        long long sum=0;
        for(long long i=0;i<strlen(n);i++)
        {
                sum=sum*radix+mm[n[i]];
                if(sum>x)
                        return 1;
        }
        if(sum == x)
                return 0;
        if(sum < x)
                return -1;
}
long long getresult(long long low,long long high,char n[],long long x)
{
        long long mid=low;
        while(low<=high)
        {
                long long b=compare(n,x,mid);
                if(b==0)
                        return mid;
                else if(b==1)
                        high=mid-1;
                else if(b==-1)
                        low=mid+1;
                mid=(low+high)/2;
        }
        return -1;
}
int main()
{
        long long i;
        for(i='0';i<='9';i++)
                mm[i]=i-'0';
        for(i = 'a' ; i <='z' ; i++)
                mm[i] = 10 + i - 'a';
        char n1[21];
        char n2[21];
        char ctem[21];
        long long tag;
        long long radix;
        scanf("%s%s%lld%lld",n1,n2,&tag,&radix);
        if(tag == 2)
        {
                strcpy(ctem,n2);
                strcpy(n2,n1);
                strcpy(n1,ctem);
        }
        long long x = getx(n1,radix);
        long long low = getlow(n2);
        long long high = x + 1;
        long long result = getresult(low,high,n2,x);
        if(result == -1)
                printf("Impossible\n");
        else
                printf("%lld\n",result);
        return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值