hdu2609

How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2768    Accepted Submission(s): 1191


Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.
 

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
 

Output
For each test case output a integer , how many different necklaces.
 

Sample Input
  
  
4 0110 1100 1001 0011 4 1010 0101 1000 0001
 

Sample Output
  
  
1

2

题意分析:

有n个环形字符串,一个环形字符串移动会形成不同的字符串,我们把它们看作同一串字符串,求有多少个不同的字符串?

用最小表示法将一个环形串的最小字典序找出来,然后让这个环形串按照这个顺序来组成一个新的串,其他串都这样处理,然后去重

AC代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[10005][105];
struct node
{
    char ch[105];
}t[10005];
int cmp(const node a,const node b)
{
    if(strcmp(a.ch,b.ch)<0)
    return 1;
    else
    return 0;
}
int work(int m,char str[])
{
    int i,j,l;
    i=0; j=1;
    while(i<m && j<m)
    {
        for(l=0;l<m;l++) 
            if(str[(i+l)%m]!=str[(j+l)%m]) break;
        if(l>m) break;
        if(str[(i+l)%m] > str[(j+l)%m])
            i=i+l+1;
        else
            j=j+l+1;
        if(i==j) j=i+1;
    }
    if(i<j) return i;
    return j;
}
int main()
{
    int n;
    while(scanf("%d",&n)>0)
    {
        for(int i=1;i<=n;i++)
        scanf("%s",s[i]);
        for(int i=1;i<=n;i++)
        {
            int len=strlen(s[i]);
            int cnt=work(len,s[i]);
            strcpy(t[i].ch,s[i]+cnt);
            s[i][cnt]='\0';
            strcpy(t[i].ch+len-cnt,s[i]);
        }
        sort(t+1,t+1+n,cmp);
        int sum=1;
        for(int i=2;i<=n;i++)
        {
            if(strcmp(t[i-1].ch,t[i].ch)!=0)
            sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值