hdu2609(字符串个数)

Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me 
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some). 
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110. 

Input

The input contains multiple test cases. 
Each test case include: first one integers n. (2<=n<=10000) 
Next n lines follow. Each line has a equal length character string. (string only include '0','1'). 

Output

For each test case output a integer , how many different necklaces.

Sample Input

4
0110
1100
1001
0011
4
1010
0101
1000
0001

Sample Output

1
2

题意:

一个字符串和他向左移的字符串是同一个。

比如说110,101,011.是一个字符串。

给出n个字符串求字符串的种数。

做法就是把每一个字符串都用最小表示法求出最小的。用mp标记看一共有多少个。

代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include<map>
using namespace std;
char s[11000];
map<string,int> mp;
string Get_min(char *s)
{
    int n = strlen(s);
    int i = 0,j = 1,k = 0,t;
    //表示从i开始k长度和从j开始k长度的字符串相同
    while(i < n && j < n && k < n)
    {
        t = s[(i+k)%n] - s[(j+k)%n];
        //t用来计算相对应位置上那个字典序较大
        if(!t) k++;//字符相等的情况
        else
        {
            if(t > 0) i += k+1;//i位置大
            else j += k+1;//j位置大
            if(i == j) j++;
            k = 0;
        }
    }
    char st[100000];
    int x=min(i,j);
    //return i >j ?j :i;
    for(int i=0;i<n;i++)
    {
        st[i]=s[(x+i)%n];
    }
    return st;
}
int main()
{

    int n;
    while(cin>>n)
    {
         mp.clear();
         int cnt=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%s",&s);
            //cout<<Get_min(s)<<endl;

            if(mp[Get_min(s)]==0)
            {
                cnt++;
                mp[Get_min(s)]=1;
            }
        }
        cout<<cnt<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值