HDU - 2609——How many (最多不重复循环串)

Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.
Input The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
Output For each test case output a integer , how many different necklaces. Sample Input
4
0110
1100
1001
0011
4
1010
0101
1000
0001
Sample Output
 

1 2


题意:串是循环的,求不同串个数。

思路:用最小表示法处理每一个串,然后用set容器去重。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<set>
using namespace std;
char a[110],b[110];
set<string>q;
void posmim()
{
    int len=strlen(a);
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len)
    {
        int pan=a[(i+k)%len]-a[(j+k)%len];
        if(pan==0)
            k++;
        else
        {
            if(pan>0)
                i+=k+1;
            else
                j+=k+1;
            if(i==j)
                j++;
            k=0;
        }
    }

    int tt=min(i,j);
    for(i=0;i<len;i++)
    {
        b[i]=a[(tt+i)%len];
    }
    b[len]='\0';

    q.insert(b);
}
int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%s",a);
            posmim();
        }
        printf("%d\n",q.size());
        q.clear();
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值