openjudge4.6贪心算法676:Sorting by Swapping

题目

676:Sorting by Swapping
描述
Given a permutation of numbers from 1 to n, we can always get the sequence 1, 2, 3, …, n by swapping pairs of numbers. For example, if the initial sequence is 2, 3, 5, 4, 1, we can sort them in the following way:

2 3 5 4 1
1 3 5 4 2
1 3 2 4 5
1 2 3 4 5

Here three swaps have been used. The problem is, given a specific permutation, how many swaps we needs to take at least.
输入
The first line contains a single integer t (1 <= t <= 20) that indicates the number of test cases. Then follow the t cases. Each case contains two lines. The first line contains the integer n (1 <= n <= 10000), and the second line gives the initial permutation.
输出
For each test case, the output will be only one integer, which is the least number of swaps needed to get the sequence 1, 2, 3, …, n from the initial permutation.
样例输入
2
3
1 2 3
5
2 3 5 4 1
样例输出
0
3

大意

` 没看太清,大概是从两头对调,完成排序。求最少对调次数。

思路

2 3 5 4 1
1 3 5 4 2
1 3 2 4 5
1 2 3 4 5
`从左遍历每个数,找剩下数中最小的,如果比当前是还小就交换,并记住交换次数。

数据结构

` 用结构体记住剩下数中最小数和最小数的位置。

代码

`#include <bits/stdc++.h>
using namespace std;
int t,n,d[10001];
struct node{
int id,x;
};
void view(){
cout<<“显示”<<endl;
cout<<“序号\t”;for(int i=1;i<=n;i++)cout<<i<<“\t”;cout<<endl;
cout<<“数据\t”;for(int i=1;i<=n;i++)cout<<d[i]<<“\t”;cout<<endl;
}
int main(){
//freopen(“in.cpp”,“r”,stdin);
cin>>t;
while(t–){
int m=0;
cin>>n;
for(int i=1;i<=n;i++)cin>>d[i];
for(int i=1;i<=n;i++){//从左遍历每个数
node w=node{i,d[i]};//结构体存最小数,开始是当前数
for(int j=i+1;j<=n;j++)//跟剩下的数比较
if(w.x>d[j])w.x=d[j],w.id=j;//如果比最小数还小,就是最小数
if(i!=w.id){//跟当前数不一样就交换
swap(d[i],d[w.id]);m++;
}
//view();
}
cout<<m<<endl;
}
return 0;
}

总结

阅读理解题目是第一步,
认真分析数据第二步,

  • 26
    点赞
  • 18
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值