nefu 648 Google is Feeling Lucky

Google is Feeling Lucky


Problem : 648      Time Limit : 1000ms      Memory Limit : 65536K 


description 

Google is one of the most famous Internet search engines which hosts and develops a number of Internet-based services and products. On its search engine website, an interesting button “I’m feeling lucky” attracts our eyes. This feature could allow the user skip the search result page and goes directly to the first ranked page.      Amazing! It saves a lot of time.      The question is, when one types some keywords and presses “I’m feeling lucky” button, which web page will appear? Google does a lot and come up with excellent approaches to deal with it. In this simplified problem, let us just consider that Google assigns every web page an integer-valued relevance. The most related page will be chosen. If there is a tie, all the pages with the highest relevance are possible to be chosen.      Your task is simple, given 10 web pages and their relevance. Just pick out all the possible candidates which will be served to the user when “I’m feeling lucky”.


input

The input contains multiple test cases. The number of test cases T is in the first line of the input file.      For each test case, there are 10 lines, describing the web page and relevance. Each line contains a character string without any blank characters denoting the URL of this web page and an integer Vi denoting the relevance of this web page. The length of the URL is between 1 and 100 inclusively. (1<=Vi<=100)


output  

For each test case, output several lines which are the URLs of the web pages which are possible to be chosen. The order of the URLs is the same as the input.      Please look at the sample output for further information of output format. 


sample_input 

www.youtube.com 1 

www.google.com 2 

www.google.com.hk 3 

www.alibaba.com 10 

www.taobao.com 5 

www.bad.com 10 

www.good.com 7 

www.fudan.edu.cn 8 

www.university.edu.cn 9 

acm.university.edu.cn 10 

www.youtube.com 1 

www.google.com 2 

www.google.com.hk 3 

www.alibaba.com 11 

www.taobao.com 5 

www.bad.com 10 

www.good.com 7 

www.fudan.edu.cn 8 

www.university.edu.cn 9 

acm.university.edu.cn 10 


sample_output 

Case #1: 

www.alibaba.com 

www.bad.com 

acm.university.edu.cn 

Case #2: 

www.alibaba.com hint source


hint 


source


分析:

本题意思:有T组数据;对于每组数据,有10行,每行由1个字符串和1个数字组成;

请我们输出:最大数字所对应的字符串是啥?

代码:
#include <iostream>

using namespace std;

int main()
{
    int n,max,num[12];
    char s[12][102];
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
        {
            max=0;
            for(int j=1;j<=10;j++)
            {
                cin>>s[j]>>num[j];
                if(num[j]>max) max=num[j];
            }
            cout<<"Case #"<<i<<":"<<endl;
            for(int j=1;j<=10;j++)
                if(num[j]==max) cout<<s[j]<<endl;
        }
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值