Greatest Common Increasing Subsequence

题目:

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2

 

题意:

输出两对字符串的最长上升公共子串

 

思路:

 

最长公共子序列的变形题;

当前要比较的数值为s1[i],所以我们寻找s2[j]中比s1[i]小,但dp[j]最大的值,找到了就用maxx记录位置;

s2[j]==s1[i]时更新dp[j]=maxx+1;

 

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int a,b,s1[1000],s2[1000],dp[1000]={0},maxxx=-1;
        scanf("%d",&a);
        for(int i=1;i<=a;i++)
            scanf("%d",&s1[i]);
        scanf("%d",&b);
        for(int i=1;i<=b;i++)
            scanf("%d",&s2[i]);
        for(int i=1;i<=a;i++)
        {
            int maxx=0;
            for(int j=1;j<=b;j++)
            {
                if(s1[i]==s2[j])
                    dp[j]=maxx+1;
                if(s1[i]>s2[j])
                {
                    maxx=max(maxx,dp[j]);
                }
                maxxx=max(maxxx,dp[j]);
            }
        }
        printf("%d\n",maxxx);
        if(t)
            printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值