Greatest Common Increasing Subsequence(最长上升公共子序列)

Greatest Common Increasing Subsequence


This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
Output
output print L - the length of the greatest common increasing subsequence of both sequences.
Sample Input
1

5
1 4 2 5 -12
4
-12 1 2 4
Sample Output
2
输入
要求输出两个序列的最大公共递增子序列的长度。
分析:
这道题是最长上升自序列和最长公共自序列的结合,但那也没那么简单,,至少我当时做的时候对
怎么结合起来有点没头绪,感觉虽然dp是基础,但并不是呢么好学的,需要多做题多分析。
本体的核心代码是:
if(a[i]>b[j])
ma=max(ma,dp[j]);
if(a[i]==b[j])
dp[j]=ma+1;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[510],b[510],dp[510];
int main()
{
    int i,j,s1,s2,t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&s1);
        for(i=0; i<s1; i++)
            scanf("%d",&a[i]);
        scanf("%d",&s2);
        for(i=0; i<s2; i++)
            scanf("%d",&b[i]);
        int ma=0,maxx=0;
        memset(dp,0,sizeof(dp));
        for(i=0; i<s1; i++)
        {
            ma=0;
            for(j=0; j<s2; j++)
            {
                if(a[i]>b[j])
                    ma=max(ma,dp[j]);
                if(a[i]==b[j])
                    dp[j]=ma+1;
                maxx=max(maxx,dp[j]);
            }
        }

        printf("%d\n",maxx);
        if(t)
            printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值