Subway

题目:

You have just moved from a quiet Waterloo neighbourhood to a big, noisy city. Instead of getting to ride your bike to school every day, you now get to walk and take the subway. Because you don't want to be late for class, you want to know how long it will take you to get to school. 
You walk at a speed of 10 km/h. The subway travels at 40 km/h. Assume that you are lucky, and whenever you arrive at a subway station, a train is there that you can board immediately. You may get on and off the subway any number of times, and you may switch between different subway lines if you wish. All subway lines go in both directions.

Input

Input consists of the x,y coordinates of your home and your school, followed by specifications of several subway lines. Each subway line consists of the non-negative integer x,y coordinates of each stop on the line, in order. You may assume the subway runs in a straight line between adjacent stops, and the coordinates represent an integral number of metres. Each line has at least two stops. The end of each subway line is followed by the dummy coordinate pair -1,-1. In total there are at most 200 subway stops in the city.

Output

Output is the number of minutes it will take you to get to school, rounded to the nearest minute, taking the fastest route.

Sample Input

0 0 10000 1000
0 200 5000 200 7000 200 -1 -1 
2000 600 5000 600 10000 600 -1 -1

Sample Output

21

 

题意:

已知家和学校的坐标、几条铁路每个站点坐标、走路的速度和火车的速度;

问从家到学校最短时间为多少;

 

思路:

输入的时候记录每个站点的坐标,顺便记录一条铁路每个站点与站点之间通过所需要的时间;

计算所有站点之间如果用走的话所需要的时间;

利用Dijkstra算法,计算最短路;

 

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;

struct node
{
    int x,y;
}e[300];
int n;
double mp[300][300];
double len(node a,node b)
{
    double l=sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    return l;
}
void dij()
{
    int book[300]={0},k;
    double dis[300];
    for(int i=1;i<=n;i++)
        dis[i]=mp[1][i];
    book[1]=1;
    for(int i=1;i<n;i++)
    {
        double minn=0x3f3f3f3f;
        for(int j=1;j<=n;j++)
        {
            if(book[j]==0&&dis[j]<minn)
            {
                minn=dis[j];
                k=j;
            }
        }
        book[k]=1;
        for(int j=1;j<=n;j++)
        {
            if(!book[j]&&mp[k][j]!=0x3f3f3f3f&&dis[k]+mp[k][j]<dis[j])
                dis[j]=dis[k]+mp[k][j];
        }
    }
    printf("%.0f\n",dis[2]);
}

int main()
{
    for(int i=1;i<300;i++)
    {
        mp[i][i]=0;
        for(int j=i+1;j<300;j++)
        {
            mp[i][j]=0x3f3f3f3f;
            mp[j][i]=0x3f3f3f3f;
        }
    }
    scanf("%d%d%d%d",&e[1].x,&e[1].y,&e[2].x,&e[2].y);
    n=3;
    int k=3,x,y;
    while(~scanf("%d%d",&x,&y))
    {
        if(x==-1&&y==-1)
        {
            k=n;
            continue;
        }
        e[n].x=x;
        e[n].y=y;
        if(n!=k)
            mp[n][n-1]=mp[n-1][n]=len(e[n],e[n-1])*3/2000;
        n++;
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            mp[i][j]=mp[j][i]=min(mp[i][j],len(e[i],e[j])*3/500);
        }
    }
    dij();
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值