PAT_A1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1​k1​×p2​k2​×⋯×pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1​^k1​*p2​^k2​**pm​^km​, where pi​’s are prime factors of N in increasing order, and the exponent ki​ is the number of pi​ – hence when there is only one pi​, ki​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
struct fractor{
	ll x, c;
}fac[11];
ll c;
int main(){
	ll n; scanf("%lld", &n);
	ll sqr = sqrt(n), oldn = n;
	for(ll i = 2; i < sqr; i++)
		if(n % i == 0){
			while(n % i == 0){
				fac[c].c++;
				n /= i;
			}
			fac[c++].x = i;
		}
	if(n != 1){
		fac[c].x = n;
		fac[c++].c++;
	}
	printf("%lld=", oldn);
	for(ll i = 0; i < c; i++){
		if(i!=0) printf("*");
		fac[i].c==1 ? printf("%lld", fac[i].x) : printf("%lld^%lld", fac[i].x, fac[i].c);
	}
	if(oldn==1) printf("1");
	return 0;
}

总结
#数学问题/质因子分解
n==1 需要特判输出1=1,否则测试点3报错。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值