洛谷_P2895_USACO08FEB Meteor Shower S

题面翻译

题目描述

贝茜听说一场特别的流星雨即将到来:这些流星会撞向地球,并摧毁它们所撞击的任何东西。她为自己的安全感到焦虑,发誓要找到一个安全的地方(一个永远不会被流星摧毁的地方)。

如果将牧场放入一个直角坐标系中,贝茜现在的位置是原点,并且,贝茜不能踏上一块被流星砸过的土地。

根据预报,一共有 M M M 颗流星 ( 1 ≤ M ≤ 50 , 000 ) (1\leq M\leq 50,000) (1M50,000) 会坠落在农场上,其中第 i i i 颗流星会在时刻 T i T_i Ti 0 ≤ T i ≤ 1000 0 \leq T _ i \leq 1000 0Ti1000)砸在坐标为 ( X i , Y i ) ( 0 ≤ X i ≤ 300 (X_i,Y_i)(0\leq X_i\leq 300 (Xi,Yi)(0Xi300 0 ≤ Y i ≤ 300 ) 0\leq Y_i\leq 300) 0Yi300) 的格子里。流星的力量会将它所在的格子,以及周围 4 4 4 个相邻的格子都化为焦土,当然贝茜也无法再在这些格子上行走。

贝茜在时刻 0 0 0 开始行动,她只能在第一象限中,平行于坐标轴行动,每 1 1 1 个时刻中,她能移动到相邻的(一般是 4 4 4 个)格子中的任意一个,当然目标格子要没有被烧焦才行。如果一个格子在时刻 t t t 被流星撞击或烧焦,那么贝茜只能在 t t t 之前的时刻在这个格子里出现。 贝茜一开始在 ( 0 , 0 ) (0,0) (0,0)

请你计算一下,贝茜最少需要多少时间才能到达一个安全的格子。如果不可能到达输出 − 1 −1 1

输入格式

M + 1 M+1 M+1 行,第 1 1 1 行输入一个整数 M M M,接下来的 M M M 行每行输入三个整数分别为 X i , Y i , T i X_i, Y_i, T_i Xi,Yi,Ti

输出格式

贝茜到达安全地点所需的最短时间,如果不可能,则为 − 1 -1 1

题目描述

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

输入格式

* Line 1: A single integer: M

* Lines 2…M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

输出格式

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

样例 #1

样例输入 #1

4
0 0 2
2 1 2
1 1 2
0 3 5

样例输出 #1

5
#include<bits/stdc++.h>
using namespace std;
int X[] = {0, 0, 1, -1};
int Y[] = {1, -1, 0, 0};
int g[350][350], inq[350][350]; 
struct node{
	int x, y, t;
};

bool check(int x, int y, int t){
	if(0<=x && 0<= y && inq[x][y] == 0 && (g[x][y] == -1 || t < g[x][y])){
		for(int i = 0;i < 4; i++){
			int nx = x + X[i], ny = y + Y[i];
			if(nx >= 0 && ny >= 0 && g[nx][ny] != -1 && t >= g[nx][ny] ) return false;
		}
		return true;
	}
	return false;
}

int main(){
	memset(g, -1, sizeof(g));
	int m; scanf("%d", &m);
	for(int i = 0; i < m; i++){
		int x, y, t;
		scanf("%d%d%d", &x, &y, &t);
		if(g[x][y]==-1 || g[x][y] > t) g[x][y] = t;
	}
	queue<node> q;
	node e, r;
	e.x = 0; e.y = 0; e.t = 0;
	q.push(e);
	int en = 0;
	while(!q.empty()){
		node f = q.front(); q.pop();
		if(g[f.x][f.y+1]==-1 && (f.y==0 || g[f.x][f.y-1]==-1) && g[f.x+1][f.y]==-1
			&& (f.x==0 || g[f.x-1][f.y]==-1) && g[f.x][f.y]==-1){
			r = f;
			en = 1;
			break;
		}		
		for(int i = 0;i < 4; i++){
			int nx = f.x + X[i], ny = f.y + Y[i], nt = f.t + 1;
			if(check(nx, ny, nt)){
				node t;
				t.x = nx;
				t.y = ny;
				t.t = nt;
				q.push(t);
				inq[nx][ny] = 1;
			}
		}
	}
	en ? printf("%d\n", r.t) : printf("-1\n");
	return 0;
}

总结
1、 #BFS
测试点3报错,原因是会有流星在t=0时陨落,而g的初始值也恰为0,故应该改变g的初始值;
2、同一位置可能有多个流星在不同时间陨落,应以最早的时间为准。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值