HDOJ 1789 Doing Homework again

Doing Homework again
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

zichen has just come back school from the 30th ACM/ ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If zichen hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So zichen wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4 

Sample Output

0
3
5 

这道题看了几个小时。。
刚开始觉得毫无头绪,后来看了看别人的解题思路,才知道要用到打表。。当然啦,贪心是必不可少的!!
这道题有两种方法:分别是按未完成作业所扣的分从高到低排序和按老师所给期限从小到大排序,主要是细节,太难想了。。 我个人觉得还是第一种排序容易理解些。第一种解题思路:分数从高到低排好后,从第一个开始对天数打表,即分高的就在最后期限的当天完成。若遇天数相同的,就逐个往前推(注意:此时分数已从高到低排好序)。如果天数都相同了,那么扣除的分数就是最少的。
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
    int d,f;
}a[1001];
int b[10000];
bool cmp(node a,node b){
    if(a.f==b.f)
        return a.d<b.d;
    return a.f>b.f;//按扣分排序,如果扣分相同,则按天数排序
}
int main(){
    int t,n,j;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++) 
			scanf("%d",&a[i].d);
        for(int i=0;i<n;i++) 
			scanf("%d",&a[i].f);
        sort(a,a+n,cmp);
        memset(b,0,sizeof(b));//使数组b初始化为零,后面方便打表
        int ans=0;
        for(int i=0;i<n;i++){
            for(j=a[i].d;j>0;j--){//扣分高的就在那天期限完成,如有相同的天数期限,就往前推一天
                if(b[j]==0){
                    b[j]=1;
                    break;
                }    
            }
            if(j==0)//如果都相同,则扣除扣分最少的那门作业的分
              ans+=a[i].f;
        }    
        printf("%d\n",ans);
    }    
    return 0;
}   


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值