HDOJ1789 Doing Homework again 贪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14870    Accepted Submission(s): 8679




Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1257  1159  1069  1087  1231 


这题反正我想到的动归时间复杂度是N的3次方,那就算了.....
用贪心还是挺容易的。按照扣分从大到小排序,扣分一样当然是ddl小的在前面。
然后每次从一个作业的截止日期开始从后往前扫,如果有一天是空闲的话,意味着有时间完成作业,否则就要扣分。


#include <iostream>
#include <cstdio>
#include <cmath>
#include <ctime>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn = 1005;
const int inf = 1<<25;
struct node {
    int ddl,rs;
}f[maxn];

int n;
int used[maxn],tot;

bool cmp(node x, node y){
    if (x.rs!=y.rs) return x.rs>y.rs;
    else return x.ddl<y.ddl;
}

int main(){
    int t,i,j,k;
    std::ios::sync_with_stdio(false);
    cin >> t;
    while (t--) {
        cin >> n;
        for ( i=0; i<n; i++) cin >> f[i].ddl;
        for ( i=0; i<n; i++) cin >> f[i].rs;
        sort(f,f+n,cmp);
        memset(used,0,sizeof(used));
        tot = 0;
        for ( i=0; i<n; i++) {
                k = f[i].ddl;
            for (j=k; j>0; j--) if (!used[j]) {
                 used[j] =1;
                 break;
            }
            if (j == 0) tot+=f[i].rs;
        }

        printf("%d\n",tot);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值