POJ 2507Crossed ladders(二分)

20 篇文章 0 订阅
7 篇文章 0 订阅
Description
A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?



Input
Input starts with an integer T (≤ 10), denoting the number of test cases.

Each test case contains three positive floating point numbers giving the values of x, y, and c.

Output
For each case, output the case number and the width of the street in feet. Errors less than 10-6 will be ignored.

Sample Input
4
30 40 10
12.619429 8.163332 3
10 10 3
10 10 1
Sample Output
Case 1: 26.0328775442
Case 2: 6.99999923
Case 3: 8

Case 4: 9.797958971

题意:在两个房子之间有两条线,告诉你两条线长度还有交点的高度问两栋房子之间距离多远。

思路:两个三角形求出1-c/sqrt(x*x-w*w)=c/sqrt(y*y-w*w);然后二分求出距离。(距离肯定小于x,y之间较小的数)。这里不要判断s(mid)==0,精度太小计算不出来,直接在后面输出最后的mid就行了

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#define eps 1e-12
using namespace std;
double x,y,c;
double s(double w)
{
	return 1-c/sqrt(x*x-w*w)-c/sqrt(y*y-w*w);
	
}
int main()
{
	int t;
	scanf("%d",&t);
	int k=1;
	while(t--)
	{
		scanf("%lf %lf %lf",&x,&y,&c);
		int p=0;
		double l=0,r=min(x,y),mid,ans;
		while(l<=r)
		{
			mid=(l+r)/2;
			if(s(mid)>0)	
			{
				l=mid+eps;
			}
			else
			r=mid-eps;
		}
		printf("Case %d: %lf\n",k++,mid);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值