Description
The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,
For this problem, you are to write a program that can compute the last non-zero digit of any factorial for (0 <= N <= 10000). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120.
N N! 0 1 1 1 2 2 3 6 4 24 5 120 10 3628800
For this problem, you are to write a program that can compute the last non-zero digit of any factorial for (0 <= N <= 10000). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120.
Input
Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.
Output
For each integer input, the program should print exactly one line of output. Each line of output should contain the value N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain " -> " (space hyphen greater space). Column 10 must contain the single last non-zero digit of N!.
Sample Input
1 2 26 125 3125 9999
Sample Output
1 -> 1 2 -> 2 26 -> 4 125 -> 8 3125 -> 2 9999 -> 8
刚开始觉得好像很简单,结果LTE了。下面是LTE的代码:
#include <cstdio>
using namespace std;
int main(){
int n,sum,i;
while(scanf("%d",&n)){
sum = 1;
for(i=1; i<=n; i++){
sum*=i;
while(sum%10 == 0)
sum /= 10;
sum %= 100000;
}
sum %= 10;
printf("%5d -> %d\n",n,sum);
}
return 0;
}
AC代码:
#include <cstdio>
using namespace std;
int main() {
int n2, n5, i, j, n, sum;
while(scanf("%d",&n)!=EOF) {
sum= 1;
n2 = n5 = 0;
for(i=2; i<=n; i++) {
j = i;
while(j%2 == 0) {
n2++;
j /= 2;
}
while(j%5 == 0) {
n5++;
j /= 5;
}
sum = (sum * j) % 10;
}
for(i=0; i<n2-n5; i++)
sum = (sum * 2) % 10;
printf("%5d -> %d\n",n,sum);
}
return 0;
}
对每个乘数除去2和5,再继续乘下一个。最后n2 - n5去除每对2*5
然后把多出的2乘回去