UVA568 Just the Facts


 Just the Facts 

The expression N!, read as `` N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the lastnon-zero digit of anyfactorial for ($0 \le N \le 10000$). For example, if your program is asked tocompute the last nonzerodigit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000,each on its own linewith no other letters, digits or spaces. For each integer N, you shouldread the value and compute the last nonzero digit of N!.

Output 

For each integer input, the program should print exactly one line ofoutput. Each line of outputshould contain the value N, right-justified in columns 1 through 5 withleading blanks, not leadingzeroes. Columns 6 - 9 must contain `` -> " (space hyphen greater space).Column 10 must contain the single last non-zero digit of N!.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8


题目的意思就是给你一个n 算出n的阶乘的最后一位非0数是多少。。

思路就是每乘完一个,就判断求余10是不是0;如果是就一直除以10到求余10不等0为止 。就把0全去掉了。。到最后,求余10就是最后一位非0数。

有一点需要注意,如果只是去掉0,那乘到后面数还是会非常大,会爆掉,所以就一直对100000取余,虽然最大到9999,但如果是对10000取余会影响精度。


AC代码:


#include<stdio.h>

int main () {
	int num;
	int temp;
	while (scanf("%d",&num) != EOF) {
		temp = 1;
		for (int i = 1;i <=num ;i++) {
			temp = temp * i;
			while(temp % 10 == 0)
				temp = temp / 10;
			temp = temp % 100000;

		}
		temp = temp % 10;
		printf("%5d -> %d\n",num,temp);
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值