UVA 10420 List of Conquests

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3
Spain Donna Elvira
England Jane Doe
Spain Donna Anna

Sample Output

England 1

Spain 2


/*
UVa 10420 List of Conquests
Boss在很多国家有情人.
输入情人所在的国家及姓名.
输出boss在各个国家的情人数量,按字母排序输出.

*/

#include <iostream>
#include <cstdio>
#include <string>
#include <map>
using namespace std;
const int MAXN = 75;

char str1[MAXN],str2[MAXN]
map<string,int> m;

int main(){
    int n;
    cin >>n;
    getchar();              //保存输入到缓冲区
    for(int i = 0;i < n;i++){
        fgets(str1,MAXN,stdin);     //从缓冲区获取一行给字符数组str1;
        sscanf(str1,"%s",str2);     //从str1中获取第一个字符存入字符数组str2中
        string country(str2);       //将字符数组转化为字符串
        if(m.count(country))
            m[country]++;
        else
            m[country] = 1;
    }
    
    map<string,int>::iterator it;
    for(it = m.begin(),it != m.end();++it){     //迭代器遍历map输出
        cout <<it->first <<" " <<it->second <<endl; 
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值