EIGRP基本配置

EIGRP相关配置

1、EIGRP存在三张表来作为路由更新
(1)EIGRP邻居表 --------------------------show ip eigrp neighbors
(2)EIGRP拓扑表 (学习到的可到达路径)---------show ip eigrp topology
(3)EIGRP路由表 (从路径中选出最优路由)-------- show ip route eigrp

2、Eigrp的配置命令
router eigrp x
//运行 EIGRP 的整个网络的AS 号必须一致,否则无法通信。
network network-address [wildcard-mask]
//如果是主类网络即标准A、B、C 类的网络,也可直接输入网络地址
no auto-summary

3、配置实验
在这里插入图片描述
R1配置:
interface Loopback0
ip address 1.1.1.1 255.255.255.255

!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.252
duplex auto
speed auto
!

router eigrp 10
network 1.1.1.1 0.0.0.0
network 192.168.10.0 0.0.0.3
no auto-summary

R2配置
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.20.1 255.255.255.252
duplex auto
speed auto
!
router eigrp 10
network 2.2.2.2 0.0.0.0
network 192.168.10.0 0.0.0.3
network 192.168.20.0 0.0.0.3
no auto-summary

R3配置
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255

interface FastEthernet0/0
ip address 192.168.20.2 255.255.255.252
duplex auto
speed auto
!
!
router eigrp 10
network 3.3.3.3 0.0.0.0
network 192.168.20.0 0.0.0.3
no auto-summary

R1#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.10.2 Fa0/0 13 00:53:55 19 300 0 53

R1#sh ip eigrp topology
IP-EIGRP Topology Table for AS(10)/ID(100.65.40.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 2.2.2.2/32, 1 successors, FD is 156160
via 192.168.10.2 (156160/128256), FastEthernet0/0
P 3.3.3.3/32, 1 successors, FD is 158720
via 192.168.10.2 (158720/156160), FastEthernet0/0
P 1.1.1.1/32, 1 successors, FD is 128256
via Connected, Loopback0
P 192.168.10.0/30, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 192.168.20.0/30, 1 successors, FD is 30720
via 192.168.10.2 (30720/28160), FastEthernet0/0

P(passive):网络处于收敛的稳定状态

R1#sh ip route eigrp

R1#sh ip route eigrp
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/156160] via 192.168.10.2, 00:00:48, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/158720] via 192.168.10.2, 00:12:23, FastEthernet0/0
192.168.20.0/30 is subnetted, 1 subnets
D 192.168.20.0 [90/30720] via 192.168.10.2, 00:58:08, FastEthernet0/0
//如果是通过EIGRP 协议学到的路由,管理距离是90,用“D”表示。如果是通过重分布(redistribute)进入EIGRP 网络的路由(外部路由),管理距离是170,用“D EX”表示。

R1#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/56/108 ms
R1#ping 192.168.20.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms
R1#

  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值