HDU4252:A Famous City

Problem Description
After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:
- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building, or no buildings at all.
- measure the height of each building in that piece.
- write a program to calculate the minimum number of buildings.
Mr. B has finished the first two steps, the last comes to you.
 

Input
Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the input numbers will be nonnegative and less than 1,000,000,000.
 

Output
For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.
 

Sample Input
  
  
3 1 2 3 3 1 2 1
 

Sample Output
  
  
Case 1: 3 Case 2: 2
Hint
The possible configurations of the samples are illustrated below:
题意:利用题目中给定的规律寻找到最少建筑的数量。弄懂题意很重要......
数据范围不大,可以暴力试一试。
建筑的最大可能是总数减去0高度的,则答案就是最大可能减去重复的建筑。
从开始遍历,如果当前建筑低于前一个建筑,则遍历位于当前建筑前面的建筑,看是否有与其相等的。若当前建筑高于前一个建筑,说明当前建筑是单独的,继续遍历下一个建筑。具体看代码。
AC代码:
#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std;  
  
int a[1000005],x,len;  
  
int main()  
{  
    int n,i,cas = 1,ans,j;  
    while(~scanf("%d",&n))  
    {  
        ans = 0;  
        for(i = 0; i<n; i++)  
            scanf("%d",&a[i]);  
        if(a[0]==0)  
            ans++;  
        for(i = 1; i<n; i++)  
        {  
            if(a[i]==0)  
                ans++;  0高度建筑
            else  
            {  
                for(j = i-1; j>=0; j--)  
                {  
                    if(a[i]>a[j])  
                        break;  
                    else if(a[i]==a[j])  建筑重复的情况
                    {  
                        ans++;  
                        break;  
                    }  
                }  
            }  
        }  
        printf("Case %d: %d\n",cas++,n-ans); ans包括 0高度建筑与重复建筑
    }  
  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值