HDU 4252 A Famous City

A Famous City

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2206    Accepted Submission(s): 829


Problem Description
After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:
- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building, or no buildings at all.
- measure the height of each building in that piece.
- write a program to calculate the minimum number of buildings.
Mr. B has finished the first two steps, the last comes to you.
 

Input
Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the input numbers will be nonnegative and less than 1,000,000,000.
 

Output
For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.
 

Sample Input
  
  
3 1 2 3 3 1 2 1
 

Sample Output
  
  
Case 1: 3 Case 2: 2
Hint
The possible configurations of the samples are illustrated below:
 
题意:
给你n个建筑物的高度,求最少有多少个建筑物。
因为会有遮盖问题吗,所以建筑物小于等于n。
注意高度是可以等于0 的 ,代表空地!

思路:
先假设建筑物是n个,减去多的即可!
当高度是0 时,ans++。
否则从这个建筑物向前找,发现这个比前一个大,直接break  因为连不起来嘛!
发现相等 ++ans,break;
这里有些并查集的味道!
让一个做为一个代表元,让后面连续的建筑物向前找代表元,找到++ans break
最后输出n-ans即可!
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100000 + 10;
int a[maxn];
int main(){
	int n,cnt=0;
	while(scanf("%d",&n) == 1){
		for (int i = 0; i < n; ++i)scanf("%d",&a[i]);
		int ans = 0;
		for (int i = 0; i < n; ++i){
			if (a[i] == 0)++ans;
			else {
				for (int j = i - 1; j >= 0; --j){
					if (a[i] > a[j])break;
					if (a[i] == a[j]){
						++ans;
						break;
					}
				}
			}
		}
		printf("Case %d: %d\n",++cnt,n-ans);	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值