HDOJ Robberies

 

Robberies

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

Source

IDI Open 2009
做这题好纠结的,用上面的数据测试怎么老是第一个数据输出3,害我检查了N遍,但都是一样的结果,我去提交竟然是AC,我就怀疑是不是OJ的数据太弱了,明明连第一组数据都通不过,哎,后来实在火了,把devc++关了,下了几盘军棋后打开又重新运行一下竟然可以了,原来是devc++出错了。郁闷

//把银行所有的钱作为一个背包
//状态方程是  bag[v]=max(bag[v],bag[v-value[i]]*(1-caught_rate[i]) )
//必须保证上次成功逃脱,所有要乘上次逃脱的概率
//bag[v] 表示 robber 偷了v块大洋后逃脱的最大概率 
#include<iostream>
#include<cstring>
using namespace std;
double caught_rate[101],p,bag[10010]; //被抓的概率,要求总概率不超过p,
int value[101],sum;
int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
         memset(bag,0,sizeof(bag));
         bag[0]=1; //什么都不偷那么逃脱的概率是1
         sum=0; //所有银行的总值
         scanf("%lf%d",&p,&n);
         for(int i=1;i<=n;i++){
               scanf("%d%lf",&value[i],&caught_rate[i]);
               sum+=value[i];              
         }
         for(int i=1;i<=n;i++)
              for(int v=sum;v>=value[i];v--)
                   bag[v]=max(bag[v],bag[v-value[i]]*(1-caught_rate[i]) );
         int i;
         for( i=sum;i>0;i--)
                 if(bag[i]>=(1-p))                 
                       break;
         printf("%d\n",i);
    }  
   // system("pause");
    return 0;
}

 

 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值