Description
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
Input
Output
Sample Input
Sample Output
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
char map[2][25][25]; //上下两层
bool visited[2][25][25];
int N,M,T;
int d[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
struct node{
int x,y,z,time;
};
void bfs(){
queue<node>q;
node current,temp;
temp.x=temp.y=temp.z=temp.time=0;
q.push(temp);
visited[temp.x][temp.y][temp.z]=true;
while(!q.empty()){
current=q.front();
q.pop();
for(int i=0;i<4;i++){
int x=current.x;
int y=current.y+d[i][0];
int z=current.z+d[i][1];
if(y>=0 && y<N && z>=0 && z<M && !visited[x][y][z] && map[x][y][z]!='*'){
temp.x=x; temp.y=y; temp.z=z;
if(map[temp.x][temp.y][temp.z]=='#'){
visited[temp.x][temp.y][temp.z]=true;
if(temp.x==0)
temp.x=1;
else
temp.x=0;
}
visited[x][y][z]=true;
temp.time=current.time+1;
if(temp.time>T){
cout<<"NO"<<endl;
return ;
}
else if(map[temp.x][temp.y][temp.z]=='P'){
cout<<"YES"<<endl;
return ;
}
q.push(temp);
}
}
}
cout<<"NO"<<endl; //这一步别忘记了,队列空了就表示没有找到亲爱的公主
}
int main(){
int c;
cin>>c;
while(c--){
cin>>N>>M>>T;
for(int i=0;i<2;i++)
for(int j=0;j<N;j++)
for(int k=0;k<M;k++)
cin>>map[i][j][k];
for(int i=0;i<N;i++) //搜索两层
for(int j=0;j<M;j++){
if(map[0][i][j]=='#' && map[1][i][j]=='#')//上下两层都是传输机,则置为墙壁
map[0][i][j]=map[1][i][j]='*';
else if(map[0][i][j]=='#' && map[1][i][j]=='*')
map[0][i][j]=map[1][i][j]='*';
else if(map[0][i][j]=='*' && map[1][i][j]=='#')
map[0][i][j]=map[1][i][j]='*';
}
memset(visited,false,sizeof(visited));
bfs();
}
//system("pause");
return 0;
}