HDU 2054 A == B ?A

Problem B

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 122   Accepted Submission(s) : 12
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO



刚开始晕了,尽然会用BigInteger,后来用BigDecimal轻松搞定,不过,据说用c或者c++有点麻烦。。。。


AC代码:

import java.math.BigDecimal;
import java.util.Scanner;

public class hdu2504{
 public static void main(String[] args) {
  Scanner cin =new Scanner (System.in);
  while(cin.hasNext()){
   BigDecimal a = cin.nextBigDecimal();
   BigDecimal b = cin.nextBigDecimal();
   if(a.compareTo(b)==0){
    System.out.println("YES");
   }
   else{
    System.out.println("NO");
   }
  }
  
 }
}

转载于:https://www.cnblogs.com/qjack/p/3366565.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值