Poj 3624 Charm Bracelet [dp]

Poj3624 Charm Bracelet
Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

解题思路:一道简单01背包问题,给定体积和价值的物品。只需要判断是否放进去即可,就是从体积的最大值开始找,然后每一步都找到最优的情况就好了。拿样例来推就是这样子的:
物品\v 1 2 3 4 5 6
1 4 4 4 4 4 4 4
2 6 4 6 10 10 10 10
3 12 4 6 12 16 18 22
2 7 4 7 12 16 19 23

#include <stdio.h>
#include <string.h>
#define max(a,b) a>b?a:b

int main()
{
	int n,m,i,j,k;
	int c[3500],w[3500];
	int d[100010];
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(c,0,sizeof(c));
		memset(w,0,sizeof(w));
		memset(d,0,sizeof(d));
		for(i=0;i<n;i++)
			scanf("%d%d",&c[i],&w[i]);
		for(i=0;i<n;i++)
			for(j=m;j>=c[i];j--)
				d[j]=max(d[j],d[j-c[i]]+w[i]);
		printf("%d\n",d[m]);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值