poj1797 Heavy Transportation [最短路变形模板]

Heavy Transportation

题目链接 poj1797

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 44844 Accepted: 11734

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意概括

就是一个人要在一个城市里运货,有n个站点,编号为1.2.3…n.从1出发到n去。然后条路都有自己承受的重量大小也就是权值,然后求从起点到终点最大运货可以有多重。

解题思路

题目大概就是求从起点到终点的所有路径中,找到每条路的最小承受值。然后再这所有路径中找到最大的一条路。简单来理解说就是在起点到终点的无数条路的每条路都找到最小的权值路段,然后再在这n条路中找到最大的一条。

写起来就是一个最短路的变形,核心代码理解起来就是两行:

if(dis[j]<min(dis[u],map[u][j]))	//直接到达j点的权值和从u点绕行的权值比较
	dis[j]=min(dis[u],map[u][j]);   //从u点绕行的话,肯定就要选择较小的权值了。

程序代码

#include <stdio.h>
#include <string.h>
#define inf 99999999
int dis[1010];
int book[1010];
int map[1010][1010];

int min(int a,int b)
{
	if(a<b)
		return a;
	return b;
}

int main()
{
	int t,n,m,h;     //大佬们可以帮忙看看,就是在我定义这几个变量的时候先后顺序不一样的时候就会RE
	int i,j,k;
	int u,v,l;
	//int n,m;       //这样定义变量然后其他全部不变,提交就是RE
	//int t,i,j,h;
	//int u,v,l,k;
	scanf("%d",&t);
	for(h=1;h<=t;h++){
		scanf("%d%d",&n,&m);
		memset(dis,0,sizeof(dis));
		memset(map,0,sizeof(map));
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++)
				map[i][j]=-1;
			map[i][i]=0;	
		}
		while(m--){
			scanf("%d%d%d",&u,&v,&l);
			if(l>map[u][v]){
				map[u][v]=l;
				map[v][u]=l;
			}
		}
		for(i=1;i<=n;i++)
			dis[i]=map[1][i];
		book[1]=1;
		for(i=1;i<n;i++){
			int min0=-1;
			for(j=1;j<=n;j++){
				if(!book[j]&&dis[j]>min0){
					min0=dis[j];
					u=j;
				}
			}
			book[u]=1;
			for(j=1;j<=n;j++){
				if(dis[j]<min(dis[u],map[u][j]))
					dis[j]=min(dis[u],map[u][j]);
			}
		}
		printf("Scenario #%d:\n",h);
		//for(i=2;i<=n;i++)
		printf("%d\n\n",dis[n]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值