POJ3349 Snowflake Snow Snowflakes 『Hash』(CCC2007)

Snowflake Snow Snowflakes

Description



You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.


Input



The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.


Output



If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.


Sample Input



2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output


Twin snowflakes found.


这里是POJ3349:『落在地上的雪花,从上面看,还是从侧面看会找到两片一样的雪花呢?』的题解。

这里是原文就是我的wp博客啦上这里看效果更好哦点一下玩一年就看一下嘛求你啦!

题目大意:

有一堆雪花,用6个数字表示每一片花瓣的长度,顺时针或逆时针给出,问有没有两片一模一样的雪花呢?

解法:

一个简单的想法是Hash。让我们用加法求余来维护每个雪花的key值。

key=(num[1]+num[2]+num[3]+num[4]+num[5]+num[6])%H

其中H为一个较大质数,这里我选择了14997.

这样就可以保证同一个雪花的hash值相等,不同雪花的hash值不等。

(好像不能保证不同雪花的hash值不等?)

所以当我们遇到地址冲突时,判断和它地址相等的是否长得和它确实一样就好啦!

这里可以钻一个漏洞-我们可以直接排序之后逐个判断。但这样会出现一种反例:

1 2 3 4 5 6

1 4 2 5 3 6

这两个雪花不等但排序后完全相等。

但是这题数据没有这种反例(逃)

所以就水过了!

下为代码↓

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#define MAXN 100050
#define H 14997
using namespace std;
struct Hash
{
	bool aru;
	int id;	
} has[H][150];
int num[MAXN][7];
int n;
int hash(int a, int b, int c, int d, int e, int f)
{
	return (a%H + b%H + c%H	+ d%H + e%H + f) % H;
}
bool same(int i, int j)
{
	sort(num[i]+1, num[i]+7);
	sort(num[j]+1, num[j]+7); //"钻社会主义漏洞"
	for(int k = 1;k <= 6;k++)
		if(num[i][k] != num[j][k]) return 0;
	return 1;
}
bool check(int h, int v)
{
	for(int i = 1;i <= has[h][0].id;i++)
	{
		int u = has[h][i].id;
		if(same(u, v)) return 0;
	}
	return 1;
}
int main()
{
	memset(has, 0, sizeof(has));
	scanf("%d", &n);
	for(int i = 1;i <= n;i++)
	{
		scanf("%d%d%d%d%d%d", &num[i][1], &num[i][2], &num[i][3], &num[i][4], &num[i][5], &num[i][6]);
		int h = hash(num[i][1], num[i][2], num[i][3], num[i][4], num[i][5], num[i][6]);
		if(!has[h][1].aru)
		{
			has[h][1].aru = 1;
			has[h][0].id++;
			has[h][1].id = i;
		}
		else
		{
			if(check(h, i))
			{
				has[h][++has[h][0].id].aru = 1;
				has[h][has[h][0].id].id = i;
			}
			else
			{
				printf("Twin snowflakes found.\n");
				return 0;
			}
		}
	}
	printf("No two snowflakes are alike.\n");
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值