HDU 1828 Picture(线段树+扫描线求周长并)

Picture

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5768    Accepted Submission(s): 2740


Problem Description
A number of rectangular posters, photographs and other pictures of the same shape are pasted on a wall. Their sides are all vertical or horizontal. Each rectangle can be partially or totally covered by the others. The length of the boundary of the union of all rectangles is called the perimeter. 

Write a program to calculate the perimeter. An example with 7 rectangles is shown in Figure 1. 



The corresponding boundary is the whole set of line segments drawn in Figure 2. 



The vertices of all rectangles have integer coordinates.
 

Input
Your program is to read from standard input. The first line contains the number of rectangles pasted on the wall. In each of the subsequent lines, one can find the integer coordinates of the lower left vertex and the upper right vertex of each rectangle. The values of those coordinates are given as ordered pairs consisting of an x-coordinate followed by a y-coordinate. 

0 <= number of rectangles < 5000 
All coordinates are in the range [-10000,10000] and any existing rectangle has a positive area.

Please process to the end of file.
 

Output
Your program is to write to standard output. The output must contain a single line with a non-negative integer which corresponds to the perimeter for the input rectangles.
 

Sample Input
 
 
7 -15 0 5 10 -5 8 20 25 15 -4 24 14 0 -6 16 4 2 15 10 22 30 10 36 20 34 0 40 16
 

Sample Output
 
 
228
 

题解:
和求面积类似,不过这里横边竖边都要求。这里要注意,
边有重合的地方的情况,在求面积时是不影响的,但是
求周长不能重复相加,因此可以在排序的时候若x值相同
则先排入边后排出边(之前一直不知道怎么去重,看了一位
大神的博客是这样搞的,实在太巧妙啦)。

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=5007;
int x1[maxn],y11[maxn],x2[maxn],y2[maxn];
int x[maxn*2],y[maxn*2];
struct LINE
{
    int x,y_down,y_up;
    int flag;
} line[maxn*2];
bool cmp(const LINE& a,const LINE& b)
{
    if(a.x!=b.x)return a.x<b.x;
    return a.flag>b.flag;
}
struct TREE
{
    int x,y_down,y_up;
    int cover;
    bool flag;
} tree[maxn<<4];
int abs1(int x)
{
    if(x<0)return -x;
    return x;
}
void build(int l,int r,int rt)
{
    tree[rt].x=-1;
    tree[rt].y_down=y[l];
    tree[rt].y_up=y[r];
    tree[rt].flag=0;
    tree[rt].cover=0;
    if(l+1==r)
    {
        tree[rt].flag=1;
        return;
    }
    build(l,(l+r)>>1,rt<<1);
    build((l+r)>>1,r,rt<<1|1);
}
int query(int x,int l,int r,int rt,int flag)
{
    if(r<=tree[rt].y_down||l>=tree[rt].y_up)
        return 0;
    if(tree[rt].flag)
    {
        if(tree[rt].cover<=0)
        {
            tree[rt].cover+=flag;
            int ans=abs1(tree[rt].y_up-tree[rt].y_down);
            tree[rt].x=x;
            return ans;
        }
        else
        {
            tree[rt].cover+=flag;
            tree[rt].x=x;
            return 0;
        }
    }
    return query(x,l,r,rt<<1,flag)+query(x,l,r,rt<<1|1,flag);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int i,j;
        if(n==0)
        {
            printf("0\n");
            continue;
        }
        for(i=1; i<=n; i++)
            scanf("%d%d%d%d",&x1[i],&y11[i],&x2[i],&y2[i]);
        int t=0;
        for(i=1; i<=n; i++)
        {
            t++;
            y[t]=y11[i];
            line[t].x=x1[i];
            line[t].y_down=y11[i];
            line[t].y_up=y2[i];
            line[t].flag=1;
            t++;
            y[t]=y2[i];
            line[t].x=x2[i];
            line[t].y_down=y11[i];
            line[t].y_up=y2[i];
            line[t].flag=-1;
        }
        sort(y+1,y+t+1);
        sort(line+1,line+t+1,cmp);
        build(1,t,1);
        int ans=0;
        for(i=1; i<=t; i++)
            ans+=query(line[i].x,line[i].y_down,line[i].y_up,1,line[i].flag);
        t=0;
        for(i=1; i<=n; i++)
        {
            t++;
            y[t]=x1[i];
            line[t].x=y11[i];
            line[t].y_down=x1[i];
            line[t].y_up=x2[i];
            line[t].flag=1;
            t++;
            y[t]=x2[i];
            line[t].x=y2[i];
            line[t].y_down=x1[i];
            line[t].y_up=x2[i];
            line[t].flag=-1;
        }
        sort(y+1,y+t+1);
        sort(line+1,line+t+1,cmp);
        build(1,t,1);
        for(i=1; i<=t; i++)
            ans+=query(line[i].x,line[i].y_down,line[i].y_up,1,line[i].flag);
        printf("%d\n",2*ans);
        //边是对称的,求的时候只求了一条。
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值