L2-012. 关于堆的判断(堆的判断)

L2-012. 关于堆的判断

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • “x is the root”:x是根结点;
  • “x and y are siblings”:x和y是兄弟结点;
  • “x is the parent of y”:x是y的父结点;
  • “x is a child of y”:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T

#include<cstdio>
#include<map>
#include<string>
#include<string.h>
using namespace std;
int heap[1007];
char t[55];
map<int,int>mp;
void up(int id)
{
    int temp=heap[id];
    while(id/2&&temp<heap[id/2])
    {
        heap[id]=heap[id/2];
        id=id/2;
    }
    heap[id]=temp;
}
int main()
{
    int n,m;scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&heap[i]);
        up(i);
    }
    for(int i=1;i<=n;i++)
        mp[heap[i]]=i;
    getchar();
    while(m--)
    {
        gets(t);
        int x=1e9,y=1e9,L=strlen(t),q=0;
        for(int i=0;i<L;i++)
        {
            if(t[i]=='t')q++;
            if((t[i]>='0'&&t[i]<='9')||t[i]=='-')
            {
                int s=0,ans=1;
                if(t[i]=='-')ans=-1,i++;//注意x,y可能是负数
                for( ;i<L;i++)
                {
                    if(!(t[i]>='0'&&t[i]<='9'))break;
                    s=s*10+t[i]-'0';
                }
                if(x==1e9)x=s*ans;
                else y=s*ans;
            }
        }
        if(y==1e9)
        {
            if(mp[x]==1)printf("T\n");
            else printf("F\n");
        }
        else if(t[L-1]=='s')
        {
            if(mp[x]/2==mp[y]/2)printf("T\n");
            else printf("F\n");
        }
        else if(q)
        {
            if(mp[x]==mp[y]/2)printf("T\n");
            else printf("F\n");
        }
        else
        {
            if(mp[y]==mp[x]/2)printf("T\n");
            else printf("F\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值