L2-006 树的遍历分数 (二叉树的建立与遍历)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

分析:根据左子树或右子树区间(既last又in)找到根节点,在判断根节点左子树节点数量,再递归求解。详细看代码注释

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int n;
int last[35];int in[35];last是后序遍历的序列数组,in是中序遍历的序列的数组
struct node{
	int data;
	node* l;
	node* r;
	node(int num){
		data=num;
		l=NULL;
		r=NULL;
	}
};              //lastl是last数组的左边界
node* buildtree(int lastl,int lastr,int inl,int inr){//建树
	if(lastl>lastr)return NULL;
	node* root=new node(last[lastr]);  //根据后续遍历左子树-右子树-根,最后一个是根,找到它
	//root->data=last[lastr];
	int i;
	for(i=inl;i<=inr;i++){
		if(in[i]==root->data)break;    //找到找到的根节点在in的位置,他左边为左子树,右边为右子树
	}
	int numleft=i-inl;                //确定找的的根节点的左子树的节点数量
	root->l=buildtree(lastl,lastl+numleft-1,inl,i-1);
          //分别是左子树在last数组对应的范围和在in数组对应的范围(不包括该根节点)
	root->r=buildtree(lastl+numleft,lastr-1,i+1,inr);
	return root;
}
void level(node* root){
	queue<node*>q;
	q.push(root);
	int cnt=0;
	while(!q.empty()){
		node* tmp=q.front();q.pop();
		if(cnt!=0)cout<<" ";
		cout<<tmp->data;
		cnt++;
		if(tmp->l!=NULL)q.push(tmp->l);  //这个if很重要。
		if(tmp->r!=NULL)q.push(tmp->r);
	}
	return ;
}
int main (){
	cin>>n;
	int i;
	for(i=1;i<=n;i++){
		cin>>last[i];
	}
	for(i=1;i<=n;i++){
		cin>>in[i];
	}
	node* root=buildtree(1,n,1,n);
	level(root);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值