Best Cow Line POJ - 3617(贪心)

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

解题思路:

贪心策略,将字符串左位置元素与字符串右位置元素比较,将较小的那个串到新的字符串上去,

注意每输出80个字符要换行。。。

这题的难点是左右相等的情况,这时我们要进一步比较,我这一题在这个点超时了

我们在while里再套用一个for循环进行比较,循环直到左右两字符不再相等为止,这样就不会超时了

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN = 2010;
int N;
char tstr[MAXN];
int main() {
	while (scanf("%d", &N) != EOF) {
		getchar();
		for (int i = 0; i < N; ++i) {
			scanf("%c", &tstr[i]);
			getchar();
		}
		int pointL = 0;
		int pointR = N - 1;
		int index = 0;
		int tcount = 0;
		while (pointL <= pointR) {
			if (pointL == pointR) {
				printf("%c", tstr[pointL]);
				tcount++;
				break;
			}
			bool isLeft = false;
			for (int i = 0; pointL + i <= pointR; ++i) {
				if (tstr[pointL + i] < tstr[pointR - i]) {
					isLeft = true;
					tcount++;
					break;
				}
				else if (tstr[pointL + i] > tstr[pointR - i]) {
					isLeft = false;
					tcount++;
					break;
				}
			}

			if (isLeft) putchar(tstr[pointL++]);
			else putchar(tstr[pointR--]);
			if (tcount % 80 == 0) printf("\n");  //每输出80个字符要换行
		}
		putchar('\n');
	}
	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值