Best Cow Line(POJ - 3617)

Best Cow Line

 POJ - 3617 

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

思路:

  • 题目意思大概是这样:

  • 给一个定长为N的字符串S,构造一个T,长度N

    起初,T是一个空串,随后反复进行如下任意操作:

    1.从S的头部删除一个字符,加到T的尾部
    2.从S的尾部删除一个字符,加到T的尾部

    目标是最后生成的字符串T的字典序尽量小

    要求每80个字母换行输出

  • 简单贪心

  • 贪心策略很简单,将S当前首部和尾部的字母进行比较,如果前面小,就将该字母添加到T的尾部,如果后面小,同理。如果当前首部字母和尾部字母相等,则需要循环去查下一个首部字母和尾部字母的情况,要找到较小的那个,扫描的指针尽量往小的字母的那边靠

AcCode:

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int N = in.nextInt();
		char[] chars = new char[N];
		List<Character> list = new ArrayList<Character>();
		for (int i = 0; i < chars.length; i++) {
			chars[i] = in.next().charAt(0);
		}
		
		int i = 0;
		int j = chars.length-1;
		while(i<=j) {
			char beginChar = chars[i];
			char endChar = chars[j];
			
			if(i==j) {
				list.add(beginChar);
				break;
			}
			
			if(beginChar>endChar) {
				list.add(endChar);
				j--;
			}else if(beginChar<endChar) {
				list.add(beginChar);
				i++;
			}else {
				int tempI = i;
				int tempJ = j;
				
				while(tempI+1<tempJ-1 && chars[tempI]==chars[tempJ]) {
					tempI++;
					tempJ--;
				}
				
				if(chars[tempI]<=chars[tempJ]) {
					list.add(beginChar);
					i++;
				}else {
					list.add(endChar);
					j--;
				}
				
			}
		}
		
		for (int k = 1; k <= list.size(); k++) {
			System.out.print(list.get(k-1));
			if(k%80==0) {
				System.out.println();
			}
		}
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值