Yogurt factory POJ - 2393 (贪心)

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

解题思路:

把本周与前一周的价格进行比较,如果本周的价格>前一周的价格+运费,那么我们就把这一周的价格设定为前一周的价格+存储费

注意如果存储多周的话,那么总存储费就是存储费*周数

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
using namespace std;
long long totalCost = 0;
const int MAXN = 10010;
int N, S;
struct uYogurt {
	int C_i;
	int Y_i;
}uYogurts[MAXN];

int main() {
	while (scanf("%d %d", &N, &S) != EOF) {
		totalCost = 0;
		int minPrice = 0;
		for (int i = 0; i < N; ++i) {
			scanf("%d %d", &uYogurts[i].C_i, &uYogurts[i].Y_i);
		}
		//贪心策略:从前一周开始生产还是本周开始生产?如果从前一周开始生产的话,本周的价格就是前一周生产的价格+存储费
		for (int i = 1; i < N; ++i) { 
			uYogurts[i].C_i = min(uYogurts[i].C_i, uYogurts[i - 1].C_i + S);
		}
		//最后运行
		for (int i = 0; i < N; ++i) {
			totalCost += uYogurts[i].C_i*uYogurts[i].Y_i;
		}
		printf("%lld\n", totalCost);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值