HDU2141

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 23263    Accepted Submission(s): 5880


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
暴力枚举,O(n^3)爆炸
枚举前两个数,二分第三个O(n^2logn)
貌似也可能爆炸
先处理前两个数字的和O(n^2)
排序,之后枚举第三个数,
二分后两个数的和O(nlogn)
故复杂度为O(n^2)可以过数据
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<fstream>
using namespace std;


int main()
{
    int i,j;
    int Case=1;
    int l,n,m;
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
    {
        long long k=0;
        int a[l],b[n],c[m];
        long long ab[l*n+5];
        for(i=0;i<l;i++) scanf("%d",&a[i]);
        for(i=0;i<n;i++) scanf("%d",&b[i]);
        for(i=0;i<m;i++) scanf("%d",&c[i]);
        for(i=0;i<l;i++)
            for(j=0;j<n;j++)
            ab[k++]=a[i]+b[j];
        sort(ab,ab+k);
        printf("Case %d:\n",Case++);
        int s,x;
        scanf("%d",&s);
        while(s--)
        {
            scanf("%d",&x);
            int flag=0;
            for(i=0;i<m;i++)
            {
                int lo=0,hi=k-1;
                int mi;
                while(lo<=hi)
                {
                    mi=(lo+hi)/2;
                    if(ab[mi]+c[i]==x) {flag=1;break;}
                    else if(ab[mi]+c[i]<x) lo=mi+1;
                    else hi=mi-1;
                }
                if(flag) break;
            }
            if(flag) printf("YES\n");
            else printf("NO\n");


        }

    }
    return 0;

}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值